blob: 8f6de571f39e8580c64bf012479e41cf2a580a95 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Program for providing universal TLS/SSL tunneling service"
2DESCRIPTION = "SSL encryption wrapper between remote client and local (inetd-startable) or remote server."
3HOMEPAGE = "https://www.stunnel.org/"
4SECTION = "net"
5# Note: Linking stunnel statically or dynamically with other modules is making
6# a combined work based on stunnel. Thus, the terms and conditions of the GNU
7# General Public License cover the whole combination.
8LICENSE = "GPLv2"
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -05009LIC_FILES_CHKSUM = "file://COPYING.md;md5=6bae28875b3b599f8f621f4335b17955"
Brad Bishopc342db32019-05-15 21:57:59 -040010
11DEPENDS = "autoconf-archive libnsl2 openssl"
12
13SRC_URI = "ftp://ftp.stunnel.org/stunnel/archive/5.x/${BP}.tar.gz \
14 file://fix-openssl-no-des.patch \
15"
16
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050017SRC_URI[sha256sum] = "af5ab973dde11807c38735b87bdd87563a47d2fa1c72a07929fcfce80a600fe1"
Brad Bishopc342db32019-05-15 21:57:59 -040018
19inherit autotools
20
21PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6 systemd', d)} libwrap"
22
23PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
24PACKAGECONFIG[libwrap] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
25PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
26
27EXTRA_OECONF += "--with-ssl='${STAGING_EXECPREFIXDIR}' --disable-fips"
28
29# When cross compiling, configure defaults to nobody, but provides no option to change it.
30EXTRA_OEMAKE += "DEFAULT_GROUP='nogroup'"
31
32# stunnel3 is a Perl wrapper to allow use of the legacy stunnel 3.x commandline
33# syntax with stunnel >= 4.05
34PACKAGES =+ "stunnel3"
35FILES_stunnel3 = "${bindir}/stunnel3"
36RDEPENDS_stunnel3 += "${PN} perl"