blob: c8527260b26677efc8e0f3e7ca460f0d44a07360 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "Precision Time Protocol (PTP) according to IEEE standard 1588 for Linux"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5SRC_URI = "http://sourceforge.net/projects/linuxptp/files/v${PV}/linuxptp-${PV}.tgz \
6 file://build-Allow-CC-and-prefix-to-be-overriden.patch \
Andrew Geisslerd688a012020-09-18 13:36:00 -05007 file://Use-cross-cpp-in-incdefs.patch \
Brad Bishop19323692019-04-05 15:28:33 -04008 "
9
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050010SRC_URI[md5sum] = "2264cb69c9af947028835c12c89a7572"
11SRC_URI[sha256sum] = "f58f5b11cf14dc7c4f7c9efdfb27190e43d02cf20c3525f6639edac10528ce7d"
Brad Bishop19323692019-04-05 15:28:33 -040012
Andrew Geisslerd688a012020-09-18 13:36:00 -050013EXTRA_OEMAKE = "ARCH=${TARGET_ARCH} EXTRA_CFLAGS='${CFLAGS}'"
14
15export KBUILD_OUTPUT="${RECIPE_SYSROOT}"
Brad Bishop19323692019-04-05 15:28:33 -040016
17do_install () {
18 install -d ${D}/${bindir}
19 install -p ${S}/ptp4l ${D}/${bindir}
20 install -p ${S}/pmc ${D}/${bindir}
21 install -p ${S}/phc2sys ${D}/${bindir}
22 install -p ${S}/hwstamp_ctl ${D}/${bindir}
23}