blob: 4d5dbafb34cd5457737a63122a3d4f181f4a75e4 [file] [log] [blame]
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -05001SUMMARY = "Userspace utilities for fs-verity"
2DESCRIPTION = "fs-verity is a Linux kernel feature that does transparent \
3on-demand integrity/authenticity verification of the contents of read-only \
4files, using a hidden Merkle tree (hash tree) associated with the file. The \
5mechanism is similar to dm-verity, but implemented at the file level rather \
6than at the block device level."
7HOMEPAGE = "https://www.kernel.org/doc/html/latest/filesystems/fsverity.html"
8SECTION = "console"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=bc974d217b525ea216a336adb73e1220"
11
12SRCREV = "406187bb3a885e083b448b2c2aa42c22957ae629"
13SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/ebiggers/fsverity-utils.git"
14
15S = "${WORKDIR}/git"
16
17DEPENDS = "openssl"
18
19EXTRA_OEMAKE += "PREFIX=${prefix} USE_SHARED_LIB=1"
20
21do_install() {
22 oe_runmake install DESTDIR=${D}
23}
24
25PACKAGES =+ "libfsverity"
26FILES_libfsverity = "${libdir}/libfsverity*${SOLIBS}"
27
28BBCLASSEXTEND = "native nativesdk"