blob: 0ad427dff8f5b5e6e2d3e9c1c2bdcda600eb270b [file] [log] [blame]
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +05301inherit allarch
2
3SUMMARY = "Operating release identification"
4DESCRIPTION = "The /etc/openembedded-release file contains operating system identification data."
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7INHIBIT_DEFAULT_DEPS = "1"
8
9do_fetch[noexec] = "1"
10do_unpack[noexec] = "1"
11do_patch[noexec] = "1"
12do_configure[noexec] = "1"
13
14VERSION = "0"
15RELEASE_NAME = "${DISTRO_NAME} ${DISTRO} ${VERSION}"
16
17def sanitise_version(ver):
18 ret = ver.replace('+', '-').replace(' ','_')
19 return ret.lower()
20
21python do_compile () {
22 import shutil
23 release_name = d.getVar('RELEASE_NAME')
24 with open(d.expand('${B}/openemebedded-release'), 'w') as f:
25 f.write('%s\n' % release_name)
26}
27do_compile[vardeps] += "${RELEASE_NAME}"
28
29do_install () {
30 install -d ${D}${sysconfdir}
31 install -m 0644 openemebedded-release ${D}${sysconfdir}/
32}