Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | SUMMARY = "Provides a bridge between gconf and xsettings" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 2 | HOMEPAGE = "https://git.yoctoproject.org/cgit/cgit.cgi/xsettings-daemon/" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 3 | BUGTRACKER = "http://bugzilla.yoctoproject.org/" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 4 | LICENSE = "MIT" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://xsettings-manager.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \ |
| 6 | file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b" |
| 7 | DEPENDS = "gconf glib-2.0 gtk+3" |
| 8 | SECTION = "x11" |
| 9 | |
| 10 | # SRCREV tagged 0.0.2 |
| 11 | SRCREV = "b2e5da502f8c5ff75e9e6da771372ef8e40fd9a2" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 12 | SRC_URI = "git://git.yoctoproject.org/xsettings-daemon;branch=master \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 13 | file://addsoundkeys.patch \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 14 | file://70settings-daemon.sh \ |
| 15 | " |
| 16 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))" |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 20 | inherit autotools pkgconfig gconf features_check |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 22 | FILES:${PN} = "${bindir}/* ${sysconfdir}" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 23 | |
| 24 | # Requires gdk-x11-2.0 which is provided by gtk when x11 in DISTRO_FEATURES |
| 25 | REQUIRED_DISTRO_FEATURES = "x11" |
| 26 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | do_install:append () { |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 28 | install -d ${D}/${sysconfdir}/X11/Xsession.d |
| 29 | install -m 755 ${WORKDIR}/70settings-daemon.sh ${D}/${sysconfdir}/X11/Xsession.d/ |
| 30 | } |