blob: b31543d9c97898ce0e6e382ea9fcd1a1de2fdf70 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001# Copyright (c) 2012-2014 LG Electronics, Inc.
2SUMMARY = "c-ares is a C library that resolves names asynchronously."
3HOMEPAGE = "http://daniel.haxx.se/projects/c-ares/"
4SECTION = "libs"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.md;md5=fb997454c8d62aa6a47f07a8cd48b006"
7
8PV = "1.14.0+gitr${SRCPV}"
9
10SRC_URI = "\
11 git://github.com/c-ares/c-ares.git \
12 file://cmake-install-libcares.pc.patch \
13"
14SRCREV = "17dc1b3102e0dfc3e7e31369989013154ee17893"
15
16UPSTREAM_CHECK_GITTAGREGEX = "cares-(?P<pver>\d+_(\d_?)+)"
17
18S = "${WORKDIR}/git"
19
20inherit cmake pkgconfig
21
22PACKAGES =+ "${PN}-utils"
23
24FILES_${PN}-utils = "${bindir}"
25
26BBCLASSEXTEND = "native nativesdk"