blob: fa4d10b4c15de78f336877ebaa689c8d835aaedf [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Distributed block device driver for Linux"
2DESCRIPTION = "DRBD is a block device which is designed to build high \
3 availability clusters. This is done by mirroring a whole \
4 block device via (a dedicated) network. You could see \
5 it as a network raid-1."
6HOMEPAGE = "http://oss.linbit.com/drbd/"
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
9DEPENDS = "virtual/kernel"
10
11SRC_URI = "http://www.linbit.com/downloads/drbd/9.0/drbd-${PV}.tar.gz \
12 file://check_existence_of_modules_before_installing.patch"
13
14SRC_URI[md5sum] = "c1dd58043f46e9926b579aa65d4ea980"
15SRC_URI[sha256sum] = "87f72d46db9bad926415b3ab9f5f1397de8c581d2e2ec1addbdd5ce2604e6123"
16inherit module
17
18EXTRA_OEMAKE += "KDIR='${STAGING_KERNEL_DIR}'"
19
20do_install () {
21 oe_runmake install DESTDIR="${D}"
22}
Brad Bishop316dfdd2018-06-25 12:45:53 -040023
24PNBLACKLIST[drbd] = "implicit declaration of function 'setup_timer'; 4.15 head file issue?"