blob: 92853d00e819869f75f9bb577d210018d25b0f3c [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001# Copyright (C) 2018 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Crypto and TLS for C++11"
5HOMEPAGE = "https://botan.randombit.net"
6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://license.txt;md5=bf361fc63df3fa25652ee82c43b7601a"
8SECTION = "libs"
9
10
11#v2.7.0
12SRCREV = "5874000d42c338ec95a7ff24cdc0c64e70f967b5"
13SRC_URI = "git://github.com/randombit/botan.git"
14
15S = "${WORKDIR}/git"
16
17inherit python3native siteinfo lib_package
18
19CPU ?= "${TARGET_ARCH}"
20CPU_x86 = "x86_32"
21CPU_armv7a = "armv7"
22CPU_armv7ve = "armv7"
23
24do_configure() {
25 python3 ${S}/configure.py \
26 --prefix="${D}${prefix}" \
27 --cpu="${CPU}" \
28 --cc-bin="${CXX}" \
29 --cxxflags="${CXXFLAGS}" \
30 --ldflags="${LDFLAGS}" \
31 --with-endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \
32 ${@bb.utils.contains("TUNE_FEATURES","neon","","--disable-neon",d)} \
33 --with-sysroot-dir=${STAGING_DIR_TARGET} \
34 --with-build-dir="${B}" \
35 --optimize-for-size \
36 --with-stack-protector \
37 --enable-shared-library \
38 --with-python-versions=3 \
39 ${EXTRA_OECONF}
40}
41
42do_compile() {
43 oe_runmake
44}
45do_install() {
46 oe_runmake install
47 sed -i -e "s|${D}||g" ${D}${libdir}/pkgconfig/botan-2.pc
48}
49
50PACKAGES += "${PN}-python3"
51
52FILES_${PN}-python3 = "${libdir}/python3"
53
54RDEPENDS_${PN}-python3 += "python3"
55