blob: a8df444858df16be0c7f9bbb2738c165c4f91fc2 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Memory Efficient Serialization Library"
2HOMEPAGE = "https://github.com/google/flatbuffers"
3SECTION = "console/tools"
4LICENSE = "Apache-2.0"
5
6PACKAGE_BEFORE_PN = "${PN}-compiler"
7
8RDEPENDS_${PN}-compiler = "${PN}"
9RDEPENDS_${PN}-dev += "${PN}-compiler"
10
11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a873c5645c184d51e0f9b34e1d7cf559"
12
13SRCREV = "25a15950f5a24d7217689739ed8f6dac64912d62"
14
15SRC_URI = "git://github.com/google/flatbuffers.git \
16 file://0001-correct-version-for-so-lib.patch \
17 file://0001-flatbuffers-Move-EndianSwap-template-to-flatbuffers-.patch \
18 file://0002-use-__builtin_bswap16-when-building-with-clang.patch \
19 "
20
21# Make sure C++11 is used, required for example for GCC 4.9
22CXXFLAGS += "-std=c++11"
23BUILD_CXXFLAGS += "-std=c++11"
24
25EXTRA_OECMAKE += "\
26 -DFLATBUFFERS_BUILD_TESTS=OFF \
27 -DFLATBUFFERS_BUILD_SHAREDLIB=ON \
28 -DPV=${PV} \
29"
30
31inherit cmake
32
33S = "${WORKDIR}/git"
34
35FILES_${PN}-compiler = "${bindir}"
36
37BBCLASSEXTEND = "native nativesdk"