blob: eb1ff65b6305ed46c3d2495109f3dfeb3cb79400 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "C++ framework for json-rpc 1.0 and 2.0"
2DESCRIPTION = "JsonRpc-Cpp is an OpenSource implementation of JSON-RPC \
3 protocol in C++. JSON-RPC is a lightweight remote procedure \
4 call protocol similar to XML-RPC."
5HOMEPAGE = "https://github.com/cinemast/libjson-rpc-cpp"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ee72d601854d5d2a065cf642883c489b"
9
10PV = "0.7.0+git${SRCPV}"
11
12SRC_URI = "git://github.com/cinemast/libjson-rpc-cpp \
13 file://0001-cmake-replace-hardcoded-lib-CMAKE_LIBRARY_PATH-with-.patch \
14 file://0001-filedescriptorclient-Typecast-min-arguments-correctl.patch \
15 file://0001-filedescriptorserver-Include-sys-select.h-before-oth.patch \
16 file://0001-memset-and-family-needs-to-include-string.h.patch \
17 file://0002-Fix-build-problem-on-Mac.patch \
18 "
19SRCREV = "ccbdb41388bdd929828941652da816bf52a0580e"
20
21SECTION = "libs"
22
23DEPENDS = "curl jsoncpp libmicrohttpd"
24
25S = "${WORKDIR}/git"
26
27inherit cmake
28
29EXTRA_OECMAKE += "-DCOMPILE_TESTS=NO -DCOMPILE_STUBGEN=NO -DCOMPILE_EXAMPLES=NO \
30 -DBUILD_SHARED_LIBS=YES -DBUILD_STATIC_LIBS=YES \
31 -DCMAKE_LIBRARY_PATH=${libdir} \
32"