blob: 13f20eb94460c1c9f0ac8984287b22982dc6e63c [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Miscellaneous utilities specific to Debian"
2SUMMARY_${PN}-cron = "Cron scripts to control automatic debsum checking"
3DESCRIPTION = "A tool for verification of installed package files against \
4MD5 checksums debsums can verify the integrity of installed package files \
5against MD5 checksums installed by the package, or generated from a .deb \
6archive."
7DESCRIPTION_${PN}-cron = "Cron scripts to control automatic system integrity \
8checking via debsums."
9SECTION = "base"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://debian/copyright;md5=770d751553e6559e9eaefd2e11ccf7e9"
12
13SRC_URI = "http://snapshot.debian.org/archive/debian/20170530T212108Z/pool/main/d/debsums/debsums_2.2.2.tar.xz"
14SRC_URI[md5sum] = "82b0710855a7e5212d4358163a269e79"
15SRC_URI[sha256sum] = "aa61896f93a6bbfe0161c21dcd67529ae8e1ec8c3ccf244523c52c4ad8253d97"
16
17# the package is taken from snapshots.debian.org; that source is static and goes stale
18# so we check the latest upstream from a directory that does get updated
19UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/"
20
21inherit perlnative gettext
22
23do_install() {
24 install -d ${D}/${sysconfdir}/cron.daily ${D}/${sysconfdir}/cron.weekly
25 install -d ${D}/${sysconfdir}/cron.monthly ${D}${sbindir} ${D}${bindir}
26 install -d ${D}${mandir}/man1 ${D}${mandir}/man8
27 install -m 0755 debsums ${D}${bindir}/
28 install -m 0755 rdebsums ${D}${bindir}/
29 install -m 0755 debsums_init ${D}${sbindir}
30 install -m 0644 man/debsums.1 ${D}${mandir}/man1/
31 install -m 0644 man/rdebsums.1 ${D}${mandir}/man1/
32 install -m 0644 man/debsums_init.8 ${D}${mandir}/man8/
33 install -m 0644 debian/cron.daily \
34 ${D}/${sysconfdir}/cron.daily/debsums
35 install -m 0644 debian/cron.weekly \
36 ${D}/${sysconfdir}/cron.weekly/debsums
37 install -m 0644 debian/cron.monthly \
38 ${D}/${sysconfdir}/cron.monthly/debsums
39 # Must exist, defaults to empty.
40 touch ${D}/${sysconfdir}/debsums-ignore
41}
42
43PACKAGES =+ "${PN}-cron"
44
45RDEPENDS_${PN} = "dpkg dpkg-perl libfile-fnmatch-perl perl \
46 perl-module-constant perl-module-digest-md5 \
47 perl-module-errno perl-module-fcntl \
48 perl-module-file-basename perl-module-file-copy \
49 perl-module-file-find perl-module-file-glob \
50 perl-module-file-path perl-module-file-spec \
51 perl-module-file-temp perl-module-getopt-long \
52 perl-module-posix"
53
54FILES_${PN}-cron = "${sysconfdir}/cron.*"