blob: 94bfb8f87ec60a7afde0bd72eb47ca8c1b211ad2 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "A client-side C library implementing the SSH2 protocol"
2HOMEPAGE = "http://www.libssh2.org/"
3SECTION = "libs"
4
5DEPENDS = "zlib"
6
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=c5cf34fc0acb44b082ef50ef5e4354ca"
9
10SRC_URI = "http://www.libssh2.org/download/${BP}.tar.gz"
11SRC_URI[md5sum] = "3d1147cae66e2959ea5441b183de1b1c"
12SRC_URI[sha256sum] = "39f34e2f6835f4b992cafe8625073a88e5a28ba78f83e8099610a7b3af4676d4"
13
14inherit autotools pkgconfig
15
16EXTRA_OECONF += "\
17 --with-libz \
18 --with-libz-prefix=${STAGING_LIBDIR} \
19 "
20
21# only one of openssl and gcrypt could be set
22PACKAGECONFIG ??= "openssl"
23PACKAGECONFIG[openssl] = "--with-openssl --with-libssl-prefix=${STAGING_LIBDIR},--without-openssl,openssl"
24PACKAGECONFIG[gcrypt] = "--with-libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR},--without-libgcrypt,libgcrypt"
25
26BBCLASSEXTEND = "native"