blob: 442592de90f9795ff1a21ddcb0563eaf03a9ec91 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Library for controlling team network device"
2HOMEPAGE = "http://www.libteam.org/"
3SECTION = "libs/network"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
7
8DEPENDS = "libnl libdaemon jansson"
9
10SRC_URI = "git://github.com/jpirko/libteam \
11 file://0001-include-sys-select.h-for-fd_set-definition.patch \
12 file://0002-teamd-Re-adjust-include-header-order.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040013 file://0001-team_basic_test.py-disable-RedHat-specific-test.patch \
14 file://run-ptest \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015 "
16SRCREV = "91a928a56a501daac5ce8b3c16bd9943661f1d16"
17
18SRC_URI[md5sum] = "565114d70c41bff6093d8e57be284e8a"
19SRC_URI[sha256sum] = "d65286379141db141bea33424ec0507bb0f827a0bf03d9c65004bb593e3d5545"
20
21S = "${WORKDIR}/git"
22
Brad Bishop316dfdd2018-06-25 12:45:53 -040023inherit autotools pkgconfig ptest
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024
25FILES_${PN} = "${libdir}/libteam${SOLIBS} \
26"
27
28PACKAGES += "${PN}-dctl ${PN}-utils"
29FILES_${PN}-dctl = "${libdir}/libteamdctl${SOLIBS} \
30"
31FILES_${PN}-utils = "${bindir}/bond2team \
32 ${bindir}/teamd \
33 ${bindir}/teamdctl \
34 ${bindir}/teamnl \
35"
36
37RDEPENDS_${PN}-utils = "bash"
Brad Bishop316dfdd2018-06-25 12:45:53 -040038RDEPENDS_${PN}-ptest = "python"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050039
Brad Bishop316dfdd2018-06-25 12:45:53 -040040do_install_ptest() {
41 install ${S}/scripts/team_basic_test.py ${D}${PTEST_PATH}/
42}