Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Power manager for the Xfce desktop environment" |
| 2 | HOMEPAGE = "http://goodies.xfce.org/projects/applications/xfce4-power-manager" |
| 3 | SECTION = "x11" |
| 4 | |
| 5 | LICENSE = "GPLv2+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" |
| 7 | |
| 8 | inherit xfce distro_features_check |
| 9 | |
| 10 | REQUIRED_DISTRO_FEATURES = "x11" |
| 11 | |
| 12 | DEPENDS += "gtk+3 glib-2.0 dbus-glib xfconf libxfce4ui libxfce4util libnotify \ |
| 13 | libxrandr virtual/libx11 libxext xfce4-panel upower libxscrnsaver" |
| 14 | |
| 15 | SRC_URI[md5sum] = "17f0e6464ad6b3bc6a657f595bf91430" |
| 16 | SRC_URI[sha256sum] = "1ea825452343b895566068018b6d5078608f8f46ce8075ba6bbb4b848f48656b" |
| 17 | |
| 18 | EXTRA_OECONF = " \ |
| 19 | --enable-network-manager \ |
| 20 | --enable-panel-plugins \ |
| 21 | " |
| 22 | |
| 23 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 24 | PACKAGECONFIG[systemd] = "--enable-polkit, --disable-polkit, polkit" |
| 25 | |
| 26 | PACKAGES += "xfce4-powermanager-plugin" |
| 27 | |
| 28 | FILES_${PN} += " \ |
| 29 | ${datadir}/polkit-1 \ |
| 30 | ${datadir}/appdata \ |
| 31 | " |
| 32 | |
| 33 | FILES_xfce4-powermanager-plugin = " \ |
| 34 | ${libdir}/xfce4 \ |
| 35 | ${datadir}/xfce4 \ |
| 36 | " |
| 37 | |
| 38 | RDEPENDS_xfce4-powermanager-plugin = "${PN}" |
| 39 | RDEPENDS_${PN} = "networkmanager ${@bb.utils.contains('DISTRO_FEATURES','systemd','','consolekit',d)}" |
| 40 | |
| 41 | # xfce4-brightness-plugin was replaced by xfce4-powermanager-plugin |
| 42 | RPROVIDES_xfce4-powermanager-plugin += "xfce4-brightness-plugin" |
| 43 | RREPLACES_xfce4-powermanager-plugin += "xfce4-brightness-plugin" |
| 44 | RCONFLICTS_xfce4-powermanager-plugin += "xfce4-brightness-plugin" |