blob: 5d17a824f0876a507d67031f87ba6419a93cdde7 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "GLib networking extensions"
2DESCRIPTION = "glib-networking contains the implementations of certain GLib networking features that cannot be implemented directly in GLib itself because of their dependencies."
Brad Bishop004d4992018-10-02 23:54:45 +02003HOMEPAGE = "https://gitlab.gnome.org/GNOME/glib-networking/"
Brad Bishop316dfdd2018-06-25 12:45:53 -04004BUGTRACKER = "http://bugzilla.gnome.org"
5
6LICENSE = "LGPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
8
9SECTION = "libs"
10DEPENDS = "glib-2.0"
11
12SRC_URI[archive.md5sum] = "99867463f182c2767bce0c74bc9cc981"
13SRC_URI[archive.sha256sum] = "eaa787b653015a0de31c928e9a17eb57b4ce23c8cf6f277afaec0d685335012f"
14
15PACKAGECONFIG ??= "ca-certificates gnutls"
16
17# No explicit dependency as it works without ca-certificates installed
18PACKAGECONFIG[ca-certificates] = "--with-ca-certificates=${sysconfdir}/ssl/certs/ca-certificates.crt,--without-ca-certificates"
19PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
20PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy"
21PACKAGECONFIG[pkcs11] = "--with-pkcs11,--without-pkcs11,p11-kit"
22
23EXTRA_OECONF = "--without-gnome-proxy"
24
25inherit gnomebase gettext upstream-version-is-even gio-module-cache
26
27FILES_${PN} += "${libdir}/gio/modules/libgio*.so ${datadir}/dbus-1/services/"
28FILES_${PN}-dev += "${libdir}/gio/modules/libgio*.la"
29FILES_${PN}-staticdev += "${libdir}/gio/modules/libgio*.a"