blob: 6f1625bb1c8c1d8d234252ccf60b17da01010e5e [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001From c99c61e8f863a508a0793168011c98dc74abbd05 Mon Sep 17 00:00:00 2001
2From: Dominic Hargreaves <dom@earth.li>
3Date: Sat, 14 Apr 2012 11:34:05 +0100
4Subject: Invoke x-terminal-emulator rather than xterm in perl5db.pl
5
6In Debian systems, xterm might not exist or might not be the preferred
7terminal emulator. Use x-terminal-emulator instead
8
9Bug-Debian: http://bugs.debian.org/668490
10Forwarded: not-needed
11
12Patch-Name: debian/perl5db-x-terminal-emulator.patch
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013Upstream-Status: Pending
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014---
15 lib/perl5db.pl | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/lib/perl5db.pl b/lib/perl5db.pl
19index 7e7194e..c466bf3 100644
20--- a/lib/perl5db.pl
21+++ b/lib/perl5db.pl
22@@ -6960,7 +6960,7 @@ properly set up.
23 sub xterm_get_fork_TTY {
24 ( my $name = $0 ) =~ s,^.*[/\\],,s;
25 open XT,
26-qq[3>&1 xterm -title "Daughter Perl debugger $pids $name" -e sh -c 'tty 1>&3;\
27+qq[3>&1 x-terminal-emulator -T "Daughter Perl debugger $pids $name" -e sh -c 'tty 1>&3;\
28 sleep 10000000' |];
29
30 # Get the output from 'tty' and clean it up a little.