blob: ff85be723f4a620a6064ec54b801ff08c240390c [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "http://ltp.sourceforge.net"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://tools/pounder21/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
15 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
16 file://utils/ffsb-6.0-rc2/COPYING;md5=c46082167a314d785d012a244748d803 \
17"
18
19DEPENDS = "attr libaio libcap acl openssl zip-native"
20DEPENDS_append_libc-musl = " fts "
21EXTRA_OEMAKE_append_libc-musl = " LIBC=musl "
22
23# since ltp contains x86-64 assembler which uses the frame-pointer register,
24# set -fomit-frame-pointer x86-64 to handle cases where optimisation
25# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
26# earlier in CFLAGS, etc.
27CFLAGS_append_x86-64 = " -fomit-frame-pointer"
28
29CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__"
30CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
31SRCREV = "96cbf48313afa65ef4d693d3441cbfd60a8d9b27"
32
33SRC_URI = "git://github.com/linux-test-project/ltp.git \
34 file://0001-mmap15-mips64-return-EINVAL.patch \
35 file://0004-build-Add-option-to-select-libc-implementation.patch \
36 file://0005-kernel-controllers-Link-with-libfts-explicitly-on-mu.patch \
37 file://0007-fix-__WORDSIZE-undeclared-when-building-with-musl.patch \
38 file://0008-Check-if-__GLIBC_PREREQ-is-defined-before-using-it.patch \
39 file://0009-fix-redefinition-of-struct-msgbuf-error-building-wit.patch \
40 file://0018-guard-mallocopt-with-__GLIBC__.patch \
41 file://0020-getdents-define-getdents-getdents64-only-for-glibc.patch \
42 file://0021-Define-_GNU_SOURCE-for-MREMAP_MAYMOVE-definition.patch \
43 file://0023-ptrace-Use-int-instead-of-enum-__ptrace_request.patch \
44 file://0024-rt_sigaction-rt_sigprocmark-Define-_GNU_SOURCE.patch \
45 file://0026-crash01-Define-_GNU_SOURCE.patch \
46 file://0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch \
47 file://0034-periodic_output.patch \
48 file://0035-fix-test_proc_kill-hang.patch \
49 file://0036-testcases-network-nfsv4-acl-acl1.c-Security-fix-on-s.patch \
50 file://0039-commands-ar01-Fix-for-test-in-deterministic-mode.patch \
51 file://0040-read_all-Define-FNM_EXTMATCH-if-not-already-like-und.patch \
52 file://0041-cve-2017-5669-shmat-for-0-or-PAGESIZE-with-RND-flag-.patch \
53 file://0042-fs-ftest-ftest06.c-Fix-too-small-name-string-and-rel.patch \
54 file://0043-open-creat-skip-S_ISGID-check-on-files-created-by-no.patch \
55 file://0001-syscalls-fcntl-make-OFD-command-use-fcntl64-syscall-.patch \
56 file://0001-sigwaitinfo01-recent-glibc-calls-syscall-directly.patch \
57 file://0001-netns_helper.sh-use-ping-6-when-ping6-is-not-avaliab.patch \
58 file://0001-open_posix_testsuite-mmap24-2-Relax-condition-a-bit.patch \
59 "
60
61S = "${WORKDIR}/git"
62
63inherit autotools-brokensep
64
65TARGET_CC_ARCH += "${LDFLAGS}"
66
67export prefix = "/opt/ltp"
68export exec_prefix = "/opt/ltp"
69
70PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
71EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
72EXTRA_OECONF = " --with-power-management-testsuite --with-realtime-testsuite --with-open-posix-testsuite "
73# ltp network/rpc test cases ftbfs when libtirpc is found
74EXTRA_OECONF += " --without-tirpc "
75
76do_install(){
77 install -d ${D}/opt/ltp/
78 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install
79
80 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
81 # as it lacks dependency on some perl moudle such as LWP::Simple
82 # And this script previously works as a tool for analyzing failures from LTP
83 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
84 # http://khack.osdl.org to retrieve ltp test results run on
85 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
86 rm -rf ${D}/opt/ltp/bin/STPfailure_report.pl
87
88 # Copy POSIX test suite into ${D}/opt/ltp/testcases by manual
89 cp -r testcases/open_posix_testsuite ${D}/opt/ltp/testcases
90}
91
92RDEPENDS_${PN} = "\
93 acl \
94 at \
95 attr \
96 bash \
97 cpio \
98 cronie \
99 curl \
100 e2fsprogs-mke2fs \
101 expect \
102 gawk \
103 gzip \
104 iproute2 \
105 ldd \
106 libaio \
107 logrotate \
108 perl \
109 python-core \
110 procps \
111 unzip \
112 util-linux \
113 which \
114 tar \
115"
116
117FILES_${PN} += "/opt/ltp/* /opt/ltp/runtest/* /opt/ltp/scenario_groups/* /opt/ltp/testcases/bin/* /opt/ltp/testcases/bin/*/bin/* /opt/ltp/testscripts/* /opt/ltp/testcases/open_posix_testsuite/* /opt/ltp/testcases/open_posix_testsuite/conformance/* /opt/ltp/testcases/open_posix_testsuite/Documentation/* /opt/ltp/testcases/open_posix_testsuite/functional/* /opt/ltp/testcases/open_posix_testsuite/include/* /opt/ltp/testcases/open_posix_testsuite/scripts/* /opt/ltp/testcases/open_posix_testsuite/stress/* /opt/ltp/testcases/open_posix_testsuite/tools/* /opt/ltp/testcases/data/nm01/lib.a /opt/ltp/lib/libmem.a"
118
119# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
120INHIBIT_PACKAGE_STRIP_FILES = "/opt/ltp/testcases/bin/nm01 /opt/ltp/testcases/bin/ldd01"
121INSANE_SKIP_${PN} += "already-stripped staticdev"
122
123# Avoid file dependency scans, as LTP checks for things that may or may not
124# exist on the running system. For instance it has specific checks for
125# csh and ksh which are not typically part of OpenEmbedded systems (but
126# can be added via additional layers.)
127SKIP_FILEDEPS_${PN} = '1'