blob: 4fe5447a03c4eadfd24ea4a02a28defafb069dd5 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Power usage tool"
2DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
3HOMEPAGE = "http://01.org/powertop/"
4BUGTRACKER = "http://bugzilla.lesswatts.org/"
5DEPENDS = "ncurses libnl pciutils"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
9SRC_URI = "http://01.org/sites/default/files/downloads/powertop/powertop-v${PV}.tar.gz \
10"
11
12SRC_URI[md5sum] = "583518c5c4434c6e9b9c58c3920950b6"
13SRC_URI[sha256sum] = "aa7fb7d8e9a00f05e7d8a7a2866d85929741e0d03a5bf40cab22d2021c959250"
14
15UPSTREAM_CHECK_URI = "https://01.org/powertop/downloads"
16UPSTREAM_CHECK_REGEX = "powertop-[v]?(?P<pver>\d+(\.\d+)+)\.tar"
17
18inherit autotools gettext pkgconfig
19
20S = "${WORKDIR}/${BPN}-v${PV}"
21
22# we do not want libncursesw if we can
23do_configure_prepend() {
24 # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
25 sed -i -e "s/ncursesw//g" ${S}/configure.ac
26 mkdir -p ${B}/src/tuning/
27}
28
29inherit update-alternatives
30ALTERNATIVE_${PN} = "powertop"
31ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
32ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
33ALTERNATIVE_PRIORITY = "100"