blob: 1a9679f9dc8f9dca422b8b4df65b9447a3197e69 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "WebP is an image format designed for the Web"
2DESCRIPTION = "WebP is a method of lossy and lossless compression that can be \
3 used on a large variety of photographic, translucent and \
4 graphical images found on the web. The degree of lossy \
5 compression is adjustable so a user can choose the trade-off \
6 between file size and image quality. WebP typically achieves \
7 an average of 30% more compression than JPEG and JPEG 2000, \
8 without loss of image quality."
9HOMEPAGE = "https://developers.google.com/speed/webp/"
10SECTION = "libs"
11
12LICENSE = "BSD"
13LIC_FILES_CHKSUM = "file://COPYING;md5=6e8dee932c26f2dab503abf70c96d8bb \
14 file://PATENTS;md5=c6926d0cb07d296f886ab6e0cc5a85b7"
15
16SRC_URI = "http://downloads.webmproject.org/releases/webp/${BP}.tar.gz"
17SRC_URI[md5sum] = "967b8f087cb392e6cc94d5e116a120c0"
18SRC_URI[sha256sum] = "84259c4388f18637af3c5a6361536d754a5394492f91be1abc2e981d4983225b"
19
20UPSTREAM_CHECK_URI = "http://downloads.webmproject.org/releases/webp/index.html"
21
22EXTRA_OECONF = " \
23 --disable-wic \
24 --enable-libwebpmux \
25 --enable-libwebpdemux \
26 --enable-threading \
27"
28# Do not trust configure to determine if neon is available.
29#
30EXTRA_OECONF_append_arm = " \
31 ${@bb.utils.contains("TUNE_FEATURES","neon","--enable-neon","--disable-neon",d)} \
32"
33
34inherit autotools lib_package
35
36PACKAGECONFIG ??= ""
37
38# libwebpdecoder is a subset of libwebp, don't build it unless requested
39PACKAGECONFIG[decoder] = "--enable-libwebpdecoder,--disable-libwebpdecoder"
40
41# Apply for examples programs: cwebp and dwebp
42PACKAGECONFIG[gif] = "--enable-gif,--disable-gif,giflib"
43PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
44PACKAGECONFIG[png] = "--enable-png,--disable-png,,libpng"
45PACKAGECONFIG[tiff] = "--enable-tiff,--disable-tiff,tiff"
46
47# Apply only for example program vwebp
48PACKAGECONFIG[gl] = "--enable-gl,--disable-gl,mesa-glut"
49
50PACKAGES =+ "${PN}-gif2webp"
51
52DESCRIPTION_${PN}-gif2webp = "Simple tool to convert animated GIFs to WebP"
53FILES_${PN}-gif2webp = "${bindir}/gif2webp"