blob: f0fa5e723ff886cfe671b8e44148bbe3c81041c6 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "GNOME XSLT library"
2HOMEPAGE = "http://xmlsoft.org/XSLT/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
7
8SECTION = "libs"
9DEPENDS = "libxml2"
10
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011SRC_URI = "http://xmlsoft.org/sources/libxslt-${PV}.tar.gz \
12 file://fix-rvts-handling.patch \
13 "
14
Brad Bishop316dfdd2018-06-25 12:45:53 -040015SRC_URI[md5sum] = "1fc72f98e98bf4443f1651165f3aa146"
16SRC_URI[sha256sum] = "526ecd0abaf4a7789041622c3950c0e7f2c4c8835471515fd77eec684a355460"
17
18UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
19
20S = "${WORKDIR}/libxslt-${PV}"
21
22BINCONFIG = "${bindir}/xslt-config"
23
24inherit autotools pkgconfig binconfig-disabled lib_package
25
26# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
27do_configure_prepend () {
28 sed -i -e 's/ansidecl.h//' ${S}/configure.ac
29
30 # The timestamps in the 1.1.28 tarball are messed up causing this file to
31 # appear out of date. Touch it so that we don't try to regenerate it.
32 touch ${S}/doc/xsltproc.1
33}
34
35EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
36# older versions of this recipe had ${PN}-utils
37RPROVIDES_${PN}-bin += "${PN}-utils"
38RCONFLICTS_${PN}-bin += "${PN}-utils"
39RREPLACES_${PN}-bin += "${PN}-utils"
40
41
42do_install_append_class-native () {
43 create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog.xml
44}
45
46FILES_${PN} += "${libdir}/libxslt-plugins"
47FILES_${PN}-dev += "${libdir}/xsltConf.sh"
48
49BBCLASSEXTEND = "native nativesdk"