blob: f0514040e1863d2445bc4ffe05f6f578d6c722be [file] [log] [blame]
Brad Bishopbd9931f2017-04-22 16:26:22 -04001SUMMARY = "Phosphor Fan"
2DESCRIPTION = "Phosphor fan provides a set of fan monitoring and \
3control applications."
4PR = "r1"
5
6require ${PN}.inc
7
8inherit autotools pkgconfig pythonnative
9inherit obmc-phosphor-systemd
10inherit phosphor-fan
11
12S = "${WORKDIR}/git"
13
14# Common build dependencies
15DEPENDS += "autoconf-archive-native"
16DEPENDS += "python-pyyaml-native"
17DEPENDS += "python-mako-native"
18DEPENDS += "sdbusplus"
19DEPENDS += "phosphor-logging"
20
21# Package configuration
22FAN_PACKAGES = " \
23 ${PN}-presence-tach \
24 ${PN}-control \
Matt Spinlerdd7a0802017-05-01 14:29:20 -050025 ${PN}-monitor \
Brad Bishopbd9931f2017-04-22 16:26:22 -040026 phosphor-chassis-cooling-type \
27"
28PACKAGES_remove = "${PN}"
29PACKAGES += "${FAN_PACKAGES}"
Matt Spinlerdd7a0802017-05-01 14:29:20 -050030PACKAGECONFIG ??= "presence control cooling-type monitor"
Brad Bishopbd9931f2017-04-22 16:26:22 -040031SYSTEMD_PACKAGES = "${FAN_PACKAGES}"
32RDEPENDS_${PN}-dev = "${FAN_PACKAGES}"
33RDEPENDS_${PN}-staticdev = "${FAN_PACKAGES}"
34
35# --------------------------------------
36# ${PN}-presence-tach specific configuration
37PACKAGECONFIG[presence] = " \
38 --enable-presence \
39 FAN_DETECT_YAML_FILE=${STAGING_DIR_NATIVE}${presence_datadir}/config.yaml, \
40 --disable-presence, \
41 virtual/phosphor-fan-presence-config \
42 , \
43"
44RDEPENDS_${PN}-presence-tach += "sdbusplus"
45
Matt Spinlerc133ec12017-04-19 08:23:50 -050046# Needed to install into the obmc-chassis-poweron target
47TMPL_TACH = "phosphor-fan-presence-tach@.service"
48INSTFMT_TACH = "phosphor-fan-presence-tach@{0}.service"
Matt Spinlerbde651b2017-05-16 10:49:57 -050049POWERON_TGT = "obmc-chassis-poweron@{0}.target"
50FMT_TACH = "../${TMPL_TACH}:${POWERON_TGT}.requires/${INSTFMT_TACH}"
Brad Bishopbd9931f2017-04-22 16:26:22 -040051
52FILES_${PN}-presence-tach = "${sbindir}/phosphor-fan-presence-tach"
Matt Spinlerc133ec12017-04-19 08:23:50 -050053SYSTEMD_SERVICE_${PN}-presence-tach += "${TMPL_TACH}"
54SYSTEMD_LINK_${PN}-presence-tach += "${@compose_list(d, 'FMT_TACH', 'OBMC_CHASSIS_INSTANCES')}"
Brad Bishopbd9931f2017-04-22 16:26:22 -040055
56# --------------------------------------
57# ${PN}-control specific configuration
Matt Spinlerc133ec12017-04-19 08:23:50 -050058PACKAGECONFIG[control] = "--enable-control \
59 FAN_DEF_YAML_FILE=${STAGING_DIR_NATIVE}${control_datadir}/fans.yaml \
60 FAN_ZONE_YAML_FILE=${STAGING_DIR_NATIVE}${control_datadir}/zones.yaml \
61 FAN_ZONE_OUTPUT_DIR=${S}/control, \
62 --disable-control, \
63 virtual/phosphor-fan-control-fan-config \
64 phosphor-fan-control-zone-config-native \
65 , \
66"
67
68RDEPENDS_${PN}-control += "sdbusplus"
69
Matt Spinlerbde651b2017-05-16 10:49:57 -050070FAN_CONTROL_TGT = "obmc-fan-control-ready@{0}.target"
71
Matt Spinlerc133ec12017-04-19 08:23:50 -050072TMPL_CONTROL = "phosphor-fan-control@.service"
73INSTFMT_CONTROL = "phosphor-fan-control@{0}.service"
Matt Spinlerbde651b2017-05-16 10:49:57 -050074FMT_CONTROL = "../${TMPL_CONTROL}:${FAN_CONTROL_TGT}.requires/${INSTFMT_CONTROL}"
75
76TMPL_CONTROL_INIT = "phosphor-fan-control-init@.service"
77INSTFMT_CONTROL_INIT = "phosphor-fan-control-init@{0}.service"
78FMT_CONTROL_INIT = "../${TMPL_CONTROL_INIT}:${POWERON_TGT}.requires/${INSTFMT_CONTROL_INIT}"
Matt Spinlerc133ec12017-04-19 08:23:50 -050079
Brad Bishopbd9931f2017-04-22 16:26:22 -040080FILES_${PN}-control = "${sbindir}/phosphor-fan-control"
Matt Spinlerbde651b2017-05-16 10:49:57 -050081SYSTEMD_SERVICE_${PN}-control += "${TMPL_CONTROL} ${TMPL_CONTROL_INIT}"
Matt Spinlerc133ec12017-04-19 08:23:50 -050082SYSTEMD_LINK_${PN}-control += "${@compose_list(d, 'FMT_CONTROL', 'OBMC_CHASSIS_INSTANCES')}"
Matt Spinlerbde651b2017-05-16 10:49:57 -050083SYSTEMD_LINK_${PN}-control += "${@compose_list(d, 'FMT_CONTROL_INIT', 'OBMC_CHASSIS_INSTANCES')}"
Brad Bishopbd9931f2017-04-22 16:26:22 -040084
85# --------------------------------------
86# phosphor-chassis-cooling-type specific configuration
87PACKAGECONFIG[cooling-type] = "--enable-cooling-type,--disable-cooling-type,libevdev,"
88RDEPENDS_phosphor-chassis-cooling-type += "libevdev"
89FILES_phosphor-chassis-cooling-type = "${sbindir}/phosphor-cooling-type"
Matt Spinlerdd7a0802017-05-01 14:29:20 -050090
91# --------------------------------------
92# ${PN}-monitor specific configuration
93PACKAGECONFIG[monitor] = "--enable-monitor \
94 FAN_MONITOR_YAML_FILE=${STAGING_DIR_NATIVE}${monitor_datadir}/monitor.yaml \
95 FAN_MONITOR_OUTPUT_DIR=${S}/monitor, \
96 --disable-monitor, \
97 phosphor-fan-monitor-config-native \
98 , \
99"
100
101RDEPENDS_${PN}-monitor += "sdbusplus"
102
103TMPL_MONITOR = "phosphor-fan-monitor@.service"
104INSTFMT_MONITOR = "phosphor-fan-monitor@{0}.service"
Matt Spinlerbde651b2017-05-16 10:49:57 -0500105FMT_MONITOR = "../${TMPL_MONITOR}:${FAN_CONTROL_TGT}.requires/${INSTFMT_MONITOR}"
Matt Spinlerdd7a0802017-05-01 14:29:20 -0500106
107FILES_${PN}-monitor = "${sbindir}/phosphor-fan-monitor"
108SYSTEMD_SERVICE_${PN}-monitor += "${TMPL_MONITOR}"
109SYSTEMD_LINK_${PN}-monitor += "${@compose_list(d, 'FMT_MONITOR', 'OBMC_CHASSIS_INSTANCES')}"