blob: 5cbb3268b032d69311c6849f02b7e0656b48f317 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "A coroutine-based Python networking library"
2DESCRIPTION = "gevent is a coroutine-based Python networking library that uses greenlet to provide \
3a high-level synchronous API on top of the libevent event loop."
4HOMEPAGE = "http://www.gevent.org"
5LICENSE = "MIT & Python-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65"
Patrick Williams8dd68482022-10-04 07:57:18 -05007DEPENDS += "${PYTHON_PN}-greenlet libev libuv c-ares"
Andrew Geissler595f6302022-01-24 19:11:47 +00008
9RDEPENDS:${PN} = "${PYTHON_PN}-greenlet \
10 ${PYTHON_PN}-mime \
11 ${PYTHON_PN}-pprint \
12 "
13
14SRC_URI[sha256sum] = "f48b64578c367b91fa793bf8eaaaf4995cb93c8bc45860e473bf868070ad094e"
15
16inherit pypi setuptools3
17
Patrick Williams8dd68482022-10-04 07:57:18 -050018# Don't embed libraries, link to the system provided libs instead
19export GEVENTSETUP_EMBED_CARES = "0"
20export GEVENTSETUP_EMBED_LIBEV = "0"
21export GEVENTSETUP_EMBED_LIBUV = "0"
Andrew Geissler595f6302022-01-24 19:11:47 +000022
23# Delete the embedded copies of libraries so we can't accidentally link to them
24do_configure:append() {
25 rm -rf ${S}/deps
26}