blob: e254d41b4c1ba9c122ed764b97efe39a7e02c8ef [file] [log] [blame]
Brad Bishopbec4ebc2022-08-03 09:55:16 -04001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2
3#
4# Corstone-500 MACHINE
5#
6SRC_URI:append:corstone500 = " \
7 file://0001-armv7-adding-generic-timer-access-through-MMIO.patch \
8 file://0002-board-arm-add-corstone500-board.patch"
9
10#
11# Corstone1000 64-bit machines
12#
13DEPENDS:append:corstone1000 = " gnutls-native"
14CORSTONE1000_DEVICE_TREE:corstone1000-mps3 = "corstone1000-mps3"
15CORSTONE1000_DEVICE_TREE:corstone1000-fvp = "corstone1000-fvp"
16EXTRA_OEMAKE:append:corstone1000 = ' DEVICE_TREE=${CORSTONE1000_DEVICE_TREE}'
17
18SYSROOT_DIRS:append:corstone1000 = " /boot"
19
20SRC_URI:append:corstone1000 = " \
21 file://0001-cmd-load-add-load-command-for-memory-mapped.patch \
22 file://0002-arm-add-support-to-corstone1000-platform.patch \
23 file://0003-usb-common-move-urb-code-to-common.patch \
24 file://0004-usb-add-isp1760-family-driver.patch \
25 file://0005-corstone1000-enable-isp1763-usb-controller.patch \
26 file://0006-arm_ffa-introducing-Arm-FF-A-low-level-driver.patch \
27 file://0007-arm_ffa-introducing-armffa-command.patch \
28 file://0008-arm_ffa-introducing-MM-communication-with-FF-A.patch \
29 file://0009-arm_ffa-introducing-test-module-for-UCLASS_FFA.patch \
30 file://0010-arm_ffa-corstone1000-enable-FF-A-and-MM-support.patch \
31 file://0011-efi-corstone1000-introduce-EFI-capsule-update.patch \
32 file://0012-corstone1000-Update-FFA-shared-buffer-address.patch \
33 file://0013-corstone1000-Make-sure-shared-buffer-contents-are-no.patch \
34 file://0014-arm-corstone1000-fix-unrecognized-filesystem-type.patch \
35 file://0015-efi_capsule-corstone1000-pass-interface-id-and-buffe.patch \
36 file://0016-efi_boottime-corstone1000-pass-interface-id-and-kern.patch \
37 file://0017-efi_loader-corstone1000-remove-guid-check-from-corst.patch \
38 file://0018-arm_ffa-removing-the-cast-when-using-binary-OR-on-FI.patch \
39 file://0019-Return-proper-error-code-when-rx-buffer-is-larger.patch \
40 file://0020-Use-correct-buffer-size.patch \
41 file://0021-Update-comm_buf-when-EFI_BUFFER_TOO_SMALL.patch \
42 file://0022-efi_loader-populate-ESRT-table-if-EFI_ESRT-config-op.patch \
43 file://0023-efi_firmware-add-get_image_info-for-corstone1000.patch \
44 file://0024-Comment-mm_communicate-failure-log.patch \
45 file://0025-efi_loader-send-bootcomplete-message-to-secure-encla.patch \
46 file://0026-efi_loader-fix-null-pointer-exception-with-get_image.patch \
47 file://0027-arm-corstone1000-add-mmc-for-fvp.patch \
48 "
49
50#
51# FVP BASE
52#
53SRC_URI:append:fvp-base = " file://bootargs.cfg"
54
55#
56# FVP BASE ARM32
57#
58SRC_URI:append:fvp-base-arm32 = " file://0001-Add-vexpress_aemv8a_aarch32-variant.patch \
59 file://0002-Revert-vexpress64-Enable-OF_CONTROL-and-OF_BOARD-for.patch \
60 "
61
62#
63# FVP BASER
64#
65SRC_URI:append:fvp-baser-aemv8r64 = " \
66 file://0001-armv8-Add-ARMv8-MPU-configuration-logic.patch \
67 file://0002-vexpress64-add-MPU-memory-map-for-the-BASER_FVP.patch \
68 file://0003-armv8-Allow-disabling-exception-vectors-on-non-SPL-b.patch \
69 file://0004-armv8-ARMV8_SWITCH_TO_EL1-improvements.patch \
70 file://0005-armv8-Make-disabling-HVC-configurable-when-switching.patch \
71 file://0006-vexpress64-Do-not-set-COUNTER_FREQUENCY.patch \
72 file://0007-vexpress64-Enable-LIBFDT_OVERLAY-in-the-vexpress_aem.patch \
73 file://0008-armv8-Allow-PRBAR-MPU-attributes-to-be-configured.patch \
74 file://0009-armv8-Enable-icache-when-switching-exception-levels-.patch \
75 "
76
77
78#
79# Juno Machines
80#
81SRC_URI:append:juno = " file://0001-arm-juno-add-custom-bootcmd-to-autoboot-from-uEnv.tx.patch"
82
83
84#
85# TC0 and TC1 MACHINES
86#
87SRC_URI:append:tc = " \
88 file://bootargs.cfg \
89 file://0001-arm-total_compute-update-secure-dram-size.patch \
90 "