blob: 2cd00cb578771f2b2164fe9e0e2982b4175b27d6 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001# Copyright (c) 2012-2014 LG Electronics, Inc.
2SUMMARY = "c-ares is a C library that resolves names asynchronously."
3HOMEPAGE = "http://daniel.haxx.se/projects/c-ares/"
4SECTION = "libs"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.md;md5=fb997454c8d62aa6a47f07a8cd48b006"
7
8SRC_URI = "git://github.com/c-ares/c-ares.git;branch=main;protocol=https"
9SRCREV = "2aa086f822aad5017a6f2061ef656f237a62d0ed"
10
11UPSTREAM_CHECK_GITTAGREGEX = "cares-(?P<pver>\d+_(\d_?)+)"
12
13S = "${WORKDIR}/git"
14
15inherit cmake pkgconfig
16
17PACKAGES =+ "${PN}-utils"
18
19FILES:${PN}-utils = "${bindir}"
20
21BBCLASSEXTEND = "native nativesdk"