blob: 6428958f937dac7c925ca842e6eca3a9582a5d27 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "A client-side C library implementing the SSH2 protocol"
2HOMEPAGE = "http://www.libssh2.org/"
3SECTION = "libs"
4
5DEPENDS = "zlib"
6
Brad Bishop6a62e0e2019-10-21 08:11:42 -04007LICENSE = "BSD-3-Clause"
Brad Bishop19323692019-04-05 15:28:33 -04008LIC_FILES_CHKSUM = "file://COPYING;md5=c5cf34fc0acb44b082ef50ef5e4354ca"
9
10SRC_URI = "http://www.libssh2.org/download/${BP}.tar.gz"
11
12SRC_URI[md5sum] = "616efd99af3d9ef731a26bed6cee9593"
13SRC_URI[sha256sum] = "088307d9f6b6c4b8c13f34602e8ff65d21c2dc4d55284dfe15d502c4ee190d67"
14
15inherit autotools pkgconfig
16
17EXTRA_OECONF += "\
18 --with-libz \
19 --with-libz-prefix=${STAGING_LIBDIR} \
20 "
21
22# only one of openssl and gcrypt could be set
23PACKAGECONFIG ??= "openssl"
24PACKAGECONFIG[openssl] = "--with-openssl --with-libssl-prefix=${STAGING_LIBDIR},--without-openssl,openssl"
25PACKAGECONFIG[gcrypt] = "--with-libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR},--without-libgcrypt,libgcrypt"
26
27BBCLASSEXTEND = "native"