blob: ddcddd60b80d5d56c3736fcca3da9a8655d7991a [file] [log] [blame]
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05001SUMMARY = "IPython: Productive Interactive Computing"
2HOMEPAGE = "https://ipython.org"
3AUTHOR = "The IPython Development Team <ipython-dev@python.org>"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING.rst;md5=59b20262b8663cdd094005bddf47af5f"
6
7PYPI_PACKAGE = "ipython"
8
9SRC_URI[md5sum] = "1f2257d771de9d2fb40d9e3cfcea429d"
10SRC_URI[sha256sum] = "b70974aaa2674b05eb86a910c02ed09956a33f2dd6c71afc60f0b128a77e7f28"
11
12RDEPENDS_${PN} = "\
13 ${PYTHON_PN}-setuptools \
14 ${PYTHON_PN}-jedi \
15 ${PYTHON_PN}-decorator \
16 ${PYTHON_PN}-pickleshare \
17 ${PYTHON_PN}-traitlets \
18 ${PYTHON_PN}-prompt-toolkit \
19 ${PYTHON_PN}-pygments \
20 ${PYTHON_PN}-backcall \
21 ${PYTHON_PN}-pydoc \
22 ${PYTHON_PN}-debugger \
23 ${PYTHON_PN}-pexpect \
24 ${PYTHON_PN}-unixadmin \
25 ${PYTHON_PN}-misc \
26 ${PYTHON_PN}-sqlite3 \
27"
28
29inherit setuptools3 pypi