blob: 9674ec09389b8666161a238d9f24d88bde97ff13 [file] [log] [blame]
Andrew Geisslerd221e032020-07-10 16:13:21 -05001SUMMARY = "Seamless operability between C++11 and Python"
2HOMEPAGE = "https://github.com/wjakob/pybind11"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=beb87117af69fd10fbf9fb14c22a2e62"
5
Andrew Geissler748a4832020-07-24 16:24:21 -05006DEPENDS = "boost"
Andrew Geisslerd221e032020-07-10 16:13:21 -05007
Andrew Geissler748a4832020-07-24 16:24:21 -05008SRC_URI = "git://github.com/pybind/pybind11.git \
9 file://0001-Do-not-strip-binaries.patch \
10 file://0001-Do-not-check-pointer-size-when-cross-compiling.patch \
11 "
12SRCREV = "3b1dbebabc801c9cf6f0953a4c20b904d444f879"
13
14S = "${WORKDIR}/git"
15
16BBCLASSEXTEND = "native"
17
18EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF"
19
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050020inherit cmake setuptools3 python3native
21
22do_configure() {
23 cmake_do_configure
24}
25
26do_compile() {
27 distutils3_do_compile
28 cmake_do_compile
29}
30
31do_install() {
32 distutils3_do_install
33 cmake_do_install
34}