blob: 464f7b86bd155ced10c44243408a6fd6c3c9dfdb [file] [log] [blame]
George Hungce97fb12020-05-13 17:25:22 +08001SUMMARY = "OpenBMC Quanta Boot Status LED Service"
2DESCRIPTION = "OpenBMC Quanta Boot Status LED Daemon."
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8
9DEPENDS += "systemd"
Brandon Kim1e427092021-08-10 15:46:03 -070010RDEPENDS:${PN} += "bash"
George Hungce97fb12020-05-13 17:25:22 +080011
12SRC_URI = " file://boot-status-led.sh \
13 file://boot-status-led.service \
14 "
15
16do_install() {
17 install -d ${D}${bindir}
18 install -m 0755 ${WORKDIR}/boot-status-led.sh ${D}${bindir}/
19
20 install -d ${D}${systemd_system_unitdir}
21 install -m 0644 ${WORKDIR}/boot-status-led.service ${D}${systemd_system_unitdir}
22}
23
24SYSTEMD_PACKAGES = "${PN}"
Brandon Kim1e427092021-08-10 15:46:03 -070025SYSTEMD_SERVICE:${PN} = "boot-status-led.service"