blob: 5d757847abffb3af55b7931baed6dad95b9a89ec [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "CTDB is a cluster implementation of the TDB database \
2used by Samba and other projects to store temporary data. If an \
3application is already using TDB for temporary data it is very easy \
4to convert that application to be cluster aware and use CTDB instead."
5HOMEPAGE = "https://ctdb.samba.org/"
6LICENSE = "GPL-2.0+ & LGPL-3.0+ & GPL-3.0+"
7
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
9 file://${COREBASE}/meta/files/common-licenses/LGPL-3.0;md5=bfccfe952269fff2b407dd11f2f3083b \
10 file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6 \
11 "
12
13SRC_URI = "https://ftp.samba.org/pub/${PN}/${BP}.tar.gz \
14 file://01-support-cross-compile-for-linux-os.patch \
15 file://02-link-rep_snprintf-for-ltdbtool.patch \
16 file://service-ensure-the-PID-directory-is-created.patch \
17 "
18
19SRC_URI[md5sum] = "d0cd91726ff4ca2229e1b21859c94717"
20SRC_URI[sha256sum] = "d5bf3f674cae986bb6178b1db215a703ac94adc5f75fadfdcff63dcbb5e98ab5"
21
22inherit autotools-brokensep pkgconfig systemd
23
24PACKAGECONFIG ??= ""
25PACKAGECONFIG[libtdb] = "--without-included-tdb,--with-included-tdb,libtdb"
26
27PARALLEL_MAKE = ""
28
29DEPENDS += "popt libtevent libtalloc libldb"
30
31# ctdbd_wrapper requires pgrep, hence procps
32RDEPENDS_${PN} += "procps"
33
34do_configure() {
35 oe_runconf
36}
37
38do_install_append() {
39 install -d ${D}${systemd_unitdir}/system
40 install -m 0644 ${S}/config/ctdb.service ${D}${systemd_unitdir}/system
41 sed -i -e 's,/usr/sbin/,${sbindir}/,' ${D}${systemd_unitdir}/system/ctdb.service
42 sed -i -e 's,\([=\ ]\)/run/,\1${localstatedir}/run/,' ${D}${systemd_unitdir}/system/ctdb.service
43
44 rm -r ${D}/${localstatedir}/run
45}
46
47# The systemd service is disabled by default, as the service will fail to
48# start without /etc/ctdb/nodes. If the user supplies this, they can re-enable
49# the service.
50SYSTEMD_AUTO_ENABLE = "disable"
51SYSTEMD_SERVICE_${PN} = "ctdb.service"
52
53# onnode is a shell script with bashisms and bash #!
54RDEPENDS_${PN} += "bash"