blob: becf093967e8d7f7f291bfea68009cf1b9efebbc [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
12SECTION = "base"
13DEPENDS = "util-linux attr e2fsprogs lzo acl"
14RDEPENDS_${PN} = "libgcc"
15
16SRCREV = "6819fbcdcab63c2d95da1a2997e37be9a71ca533"
17SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
18 file://fix-parallel.patch \
19"
20
21inherit autotools-brokensep pkgconfig
22
23EXTRA_OECONF += "--disable-documentation"
24EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
25
26
27do_configure_prepend() {
28 sh autogen.sh
29}
30
31S = "${WORKDIR}/git"
32
33BBCLASSEXTEND = "native"