blob: 85459b6403674044a9f827df5bf143c543052659 [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Delayed job execution and batch processing"
2DESCRIPTION = "At allows for commands to be run at a particular time. Batch will execute commands when \
3the system load levels drop to a particular level."
4SECTION = "base"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
7DEPENDS = "flex flex-native \
8 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
9
10RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_DEPS}', '', d)} \
11"
12
13PAM_DEPS = "libpam libpam-runtime pam-plugin-env pam-plugin-limits"
14
15RCONFLICTS_${PN} = "atd"
16RREPLACES_${PN} = "atd"
17
18SRC_URI = "http://snapshot.debian.org/archive/debian/20160728T043443Z/pool/main/a/${BPN}/${BPN}_${PV}.orig.tar.gz \
19 file://fix_parallel_build_error.patch \
20 file://posixtm.c \
21 file://posixtm.h \
22 file://file_replacement_with_gplv2.patch \
23 file://atd.init \
24 file://atd.service \
25 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
26 file://makefile-fix-parallel.patch \
27 file://0001-remove-glibc-assumption.patch \
28 "
29
30PAM_SRC_URI = "file://pam.conf.patch \
31 file://configure-add-enable-pam.patch"
32
33SRC_URI[md5sum] = "e7bd7b785b2cbb17e133d6bdc0fb099e"
34SRC_URI[sha256sum] = "0871923cab73050b98ace020664eb2ddc1e669e4166b5abb64d864d02fcefab9"
35
36UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/a/at/"
37
38EXTRA_OECONF += "ac_cv_path_SENDMAIL=/bin/true \
39 --with-daemon_username=root \
40 --with-daemon_groupname=root \
41 --with-jobdir=/var/spool/at/jobs \
42 --with-atspool=/var/spool/at/spool \
43 ac_cv_header_security_pam_appl_h=${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'yes', 'no', d)} "
44
45inherit autotools-brokensep systemd update-rc.d
46
47INITSCRIPT_NAME = "atd"
48INITSCRIPT_PARAMS = "defaults"
49
50SYSTEMD_SERVICE_${PN} = "atd.service"
51
52copy_sources() {
53 cp -f ${WORKDIR}/posixtm.[ch] ${S}
54}
55do_patch[postfuncs] += "copy_sources"
56
57do_install () {
58 oe_runmake -e "IROOT=${D}" install
59
60 install -d ${D}${sysconfdir}/init.d
61 install -m 0755 ${WORKDIR}/atd.init ${D}${sysconfdir}/init.d/atd
62
63 # install systemd unit files
64 install -d ${D}${systemd_unitdir}/system
65 install -m 0644 ${WORKDIR}/atd.service ${D}${systemd_unitdir}/system
66 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/atd.service
67
68 if [ "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}" = "pam" ]; then
69 install -D -m 0644 ${WORKDIR}/${BP}/pam.conf ${D}${sysconfdir}/pam.d/atd
70 fi
71}