blob: 087423a04535e9836d0cf5c85d4648d4b603201f [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Compressor/archiver for creating and modifying .zip files"
2HOMEPAGE = "http://www.info-zip.org"
3SECTION = "console/utils"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004
Patrick Williamsc0f7c042017-02-23 20:41:17 -06005LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=04d43c5d70b496c032308106e26ae17d"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007
Patrick Williamsc0f7c042017-02-23 20:41:17 -06008PR = "r2"
9
Patrick Williamsc124f4f2015-09-15 14:41:29 -050010S = "${WORKDIR}/zip30"
11
Patrick Williamsc0f7c042017-02-23 20:41:17 -060012SRC_URI = "${SOURCEFORGE_MIRROR}/infozip/Zip%203.x%20%28latest%29/3.0/zip30.tar.gz \
13 file://fix-security-format.patch"
14
Patrick Williamsc124f4f2015-09-15 14:41:29 -050015SRC_URI[md5sum] = "7b74551e63f8ee6aab6fbc86676c0d37"
16SRC_URI[sha256sum] = "f0e8bb1f9b7eb0b01285495a2699df3a4b766784c1765a8f1aeedf63c0806369"
17
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018# zip.inc sets CFLAGS, but what Makefile actually uses is
19# CFLAGS_NOOPT. It will also force -O3 optimization, overriding
20# whatever we set.
Patrick Williamsc0f7c042017-02-23 20:41:17 -060021EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
22 'CFLAGS=-I. -DUNIX ${CFLAGS}' \
23 'CFLAGS_NOOPT=-I. -DUNIX ${CFLAGS}' \
24 'INSTALL=install' 'INSTALL_D=install -d' \
25 'BINFLAGS=0755'"
26
27do_compile() {
28 oe_runmake -f unix/Makefile flags IZ_BZIP2=no_such_directory
29 sed -i 's#LFLAGS1=""#LFLAGS1="${LDFLAGS}"#' flags
30 oe_runmake -f unix/Makefile generic IZ_BZIP2=no_such_directory
31}
32
33do_install() {
34 oe_runmake -f unix/Makefile prefix=${D}${prefix} \
35 BINDIR=${D}${bindir} MANDIR=${D}${mandir}/man1 \
36 install
37}
38
39BBCLASSEXTEND = "native"
40
41# exclude version 2.3.2 which triggers a false positive
42UPSTREAM_CHECK_REGEX = "^zip(?P<pver>(?!232).+)\.tgz"