blob: 7ddf671bcab4a8a0b65e9f6f12d56ab223734bb3 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001require recipes-core/images/core-image-minimal.bb
2
Patrick Williamsc0f7c042017-02-23 20:41:17 -06003# Skip processing of this recipe if linux-yocto-rt is not explicitly specified as the
4# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
5# to build multiple virtual/kernel providers.
6python () {
7 if d.getVar("PREFERRED_PROVIDER_virtual/kernel", True) != "linux-yocto-rt":
8 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
9}
10
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011DESCRIPTION = "Small image capable of booting a device with a test suite and \
12tools for real-time use. It includes the full meta-toolchain, development \
13headers and libraries to form a standalone SDK."
14DEPENDS = "linux-yocto-rt"
15
16IMAGE_FEATURES += "dev-pkgs tools-sdk tools-debug eclipse-debug tools-profile tools-testapps debug-tweaks"
17
18IMAGE_INSTALL += "rt-tests hwlatdetect kernel-dev"
19
20LICENSE = "MIT"