blob: 4336c50d6313c6613bdcf6a36dbe269f55ba294b [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Real-Time preemption testcases"
2HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
3SECTION = "tests"
4DEPENDS = "linux-libc-headers virtual/libc"
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
7 file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=e768b8da44555fe63f65e5c497844cb5 \
8 file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949"
9
10require rt-tests.inc
11inherit ptest
12
13SRC_URI += " \
14 file://run-ptest \
15 file://rt_bmark.py \
16 "
17# Do not install hwlatdetect
18EXTRA_OEMAKE += "PYLIB=''"
19
20do_install() {
21 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
22 INCLUDEDIR=${includedir}
23}
24
25do_install_ptest() {
26 cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
27}
28
29RDEPENDS_${PN}-ptest += " stress python3 python3-subprocess python3-multiprocessing python3-datetime python3-re python3-lang python3-misc"
30
31FILES_${PN} += "${prefix}/src/backfire"