blob: c2760c9ace9cd65dad9f46701ad2e7b13df98f6b [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001require grub2.inc
2
3DEPENDS += "autogen-native"
4
5DEFAULT_PREFERENCE = "-1"
6DEFAULT_PREFERENCE_arm = "1"
7
8PV = "2.00+${SRCPV}"
9SRCREV = "87de66d9d83446ecddb29cfbdf7369102c8e209e"
10SRC_URI = "git://git.savannah.gnu.org/grub.git \
11 file://grub-2.00-fpmath-sse-387-fix.patch \
12 file://autogen.sh-exclude-pc.patch \
13 file://grub-2.00-add-oe-kernel.patch \
14 file://0001-Fix-build-with-glibc-2.20.patch \
15 "
16
17S = "${WORKDIR}/git"
18
19COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*)-(linux.*|freebsd.*)'
20
21inherit autotools gettext texinfo
22
23# configure.ac has code to set this automagically from the target tuple
24# but the OE freeform one (core2-foo-bar-linux) don't work with that.
25
26GRUBPLATFORM_arm = "uboot"
27GRUBPLATFORM_aarch64 = "efi"
28GRUBPLATFORM ??= "pc"
29
30EXTRA_OECONF = "--with-platform=${GRUBPLATFORM} --disable-grub-mkfont --program-prefix="" \
31 --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
32
33do_configure_prepend() {
34 ( cd ${S}
35 ${S}/autogen.sh )
36}
37
38do_install_append () {
39 install -d ${D}${sysconfdir}/grub.d
40
41}
42
43# debugedit chokes on bare metal binaries
44INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
45
46RDEPENDS_${PN} = "diffutils freetype"
47FILES_${PN}-dbg += "${libdir}/${BPN}/*/.debug"
48
49INSANE_SKIP_${PN} = "arch"
50INSANE_SKIP_${PN}-dbg = "arch"