blob: bd4c28d9973175ae1b0a9622097e373c1e357cef [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Connman config to setup wired interface on qemu machines"
2DESCRIPTION = "This is the ConnMan configuration to set up a Wired \
3network interface for a qemu machine."
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
6
7SRC_URI_append_qemuall = " file://wired.config \
8 file://wired-setup \
9"
10PR = "r2"
11
12S = "${WORKDIR}"
13
14PACKAGE_ARCH = "${MACHINE_ARCH}"
15
16FILES_${PN} = "${localstatedir}/* ${libdir}/*"
17
18do_install() {
19 #Configure Wired network interface in case of qemu* machines
20 if test -e ${WORKDIR}/wired.config && test -e ${WORKDIR}/wired-setup; then
21 install -d ${D}${localstatedir}/lib/connman
22 install -m 0644 ${WORKDIR}/wired.config ${D}${localstatedir}/lib/connman
23 install -d ${D}${libdir}/connman
24 install -m 0755 ${WORKDIR}/wired-setup ${D}${libdir}/connman
25 fi
26}