blob: 51a76b4299ca0197c9d32c364b4fb3b7e7c4ba82 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Enables PPP dial-in through a serial connection"
2SECTION = "console/network"
3DEPENDS = "ppp"
4RDEPENDS_${PN} = "ppp"
5PR = "r8"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
8 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9
10SRC_URI = "file://host-peer \
11 file://ppp-dialin"
12
13inherit allarch useradd
14
15S = "${WORKDIR}"
16
17do_install() {
18 install -d ${D}${sysconfdir}/ppp/peers
19 install -m 0644 ${WORKDIR}/host-peer ${D}${sysconfdir}/ppp/peers/host
20
21 install -d ${D}${sbindir}
22 install -m 0755 ${WORKDIR}/ppp-dialin ${D}${sbindir}
23}
24
25USERADD_PACKAGES = "${PN}"
26USERADD_PARAM_${PN} = "--system --home /dev/null \
27 --no-create-home --shell ${sbindir}/ppp-dialin \
28 --no-user-group --gid nogroup ppp"