blob: e4d9f9718da2da4243deadc4fcac06f6dfbc54dc [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001require busybox.inc
2
3SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
4 file://get_header_tar.patch \
5 file://busybox-appletlib-dependency.patch \
6 file://busybox-udhcpc-no_deconfig.patch \
7 file://find-touchscreen.sh \
8 file://busybox-cron \
9 file://busybox-httpd \
10 file://busybox-udhcpd \
11 file://default.script \
12 file://simple.script \
13 file://hwclock.sh \
14 file://mount.busybox \
15 file://syslog \
16 file://syslog-startup.conf \
17 file://syslog.conf \
18 file://busybox-syslog.default \
19 file://mdev \
20 file://mdev.conf \
21 file://mdev-mount.sh \
22 file://umount.busybox \
23 file://defconfig \
24 file://busybox-syslog.service.in \
25 file://busybox-klogd.service.in \
26 file://fail_on_no_media.patch \
27 file://run-ptest \
28 file://inetd.conf \
29 file://inetd \
30 file://login-utilities.cfg \
31 file://recognize_connmand.patch \
32 file://busybox-cross-menuconfig.patch \
33 file://0001-ifconfig-fix-double-free-fatal-error-in-INET_sprint.patch \
34 file://0001-chown-fix-help-text.patch \
35 file://mount-via-label.cfg \
36 file://sha1sum.cfg \
37 file://sha256sum.cfg \
38 file://getopts.cfg \
39"
40
41SRC_URI[tarball.md5sum] = "7925683d7dd105aabe9b6b618d48cc73"
42SRC_URI[tarball.sha256sum] = "05a6f9e21aad8c098e388ae77de7b2361941afa7157ef74216703395b14e319a"
43
44EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"
45
46do_install_ptest () {
47 cp -r ${B}/testsuite ${D}${PTEST_PATH}/
48 cp ${B}/.config ${D}${PTEST_PATH}/
49 ln -s /bin/busybox ${D}${PTEST_PATH}/busybox
50}