blob: 840434ccd20cd9e54ac2db4239568fb0ae1577d5 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001DESCRIPTION = "SDK type target for building a standalone tarball containing python, chrpath, make, git and tar. The \
2 tarball can be used to run bitbake builds on systems which don't meet the usual version requirements."
3SUMMARY = "Standalone tarball for running builds on systems with inadequate software"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
6 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
8TOOLCHAIN_TARGET_TASK ?= ""
9
10TOOLCHAIN_HOST_TASK ?= "\
11 nativesdk-python-core \
12 nativesdk-python-modules \
13 nativesdk-python-misc \
14 nativesdk-python-git \
15 nativesdk-python-pexpect \
16 nativesdk-ncurses-terminfo-base \
17 nativesdk-chrpath \
18 nativesdk-tar \
19 nativesdk-buildtools-perl-dummy \
20 nativesdk-git \
21 nativesdk-git-perltools \
22 nativesdk-pigz \
23 nativesdk-make \
24 nativesdk-wget \
25 nativesdk-ca-certificates \
26 "
27
28SDK_PACKAGE_ARCHS =+ "buildtools-dummy-${SDKPKGSUFFIX}"
29
30TOOLCHAIN_OUTPUTNAME ?= "${SDK_NAME}-buildtools-nativesdk-standalone-${DISTRO_VERSION}"
31
32SDK_TITLE = "Build tools"
33
34RDEPENDS = "${TOOLCHAIN_HOST_TASK}"
35
36EXCLUDE_FROM_WORLD = "1"
37
38inherit meta
39inherit populate_sdk
40inherit toolchain-scripts
41
42create_sdk_files_append () {
43 rm -f ${SDK_OUTPUT}/${SDKPATH}/site-config-*
44 rm -f ${SDK_OUTPUT}/${SDKPATH}/environment-setup-*
45 rm -f ${SDK_OUTPUT}/${SDKPATH}/version-*
46
47 # Generate new (mini) sdk-environment-setup file
48 script=${1:-${SDK_OUTPUT}/${SDKPATH}/environment-setup-${SDK_SYS}}
49 touch $script
50 echo 'export PATH=${SDKPATHNATIVE}${bindir_nativesdk}:$PATH' >> $script
51 # In order for the self-extraction script to correctly extract and set up things,
52 # we need a 'OECORE_NATIVE_SYSROOT=xxx' line in environment setup script.
53 # However, buildtools-tarball is inherently a tool set instead of a fully functional SDK,
54 # so instead of exporting the variable, we use a comment here.
55 echo '#OECORE_NATIVE_SYSROOT="${SDKPATHNATIVE}"' >> $script
56 toolchain_create_sdk_version ${SDK_OUTPUT}/${SDKPATH}/version-${SDK_SYS}
57
58 echo 'export GIT_SSL_CAINFO="${SDKPATHNATIVE}${sysconfdir}/ssl/certs/ca-certificates.crt"' >>$script
59}