blob: 2a2851283b0e689ac76835c423825552251aee83 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Automated text and program generation tool"
2DESCRIPTION = "AutoGen is a tool designed to simplify the creation and\
3 maintenance of programs that contain large amounts of repetitious text.\
4 It is especially valuable in programs that have several blocks of text\
5 that must be kept synchronized."
6HOMEPAGE = "http://www.gnu.org/software/autogen/"
7SECTION = "devel"
8LICENSE = "GPLv3"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11SRC_URI = "${GNU_MIRROR}/autogen/rel${PV}/autogen-${PV}.tar.gz \
12 file://increase-timeout-limit.patch \
13 file://mk-tpl-config.sh-force-exit-value-to-be-0-in-subproc.patch \
14 file://redirect-output-dir.patch \
15"
16
17SRC_URI[md5sum] = "385d7c7dfbe60babbee261c054923a53"
18SRC_URI[sha256sum] = "7bbdb73b5518baf64c6d3739fb2ecc66d2cccda888ce5ad573abe235ab5d96ba"
19
20DEPENDS = "guile-native libtool-native libxml2-native"
21
22inherit autotools texinfo native pkgconfig
23
24# autogen-native links against libguile which may have been relocated with sstate
25# these environment variables ensure there isn't a relocation issue
26export GUILE_LOAD_PATH = "${STAGING_DATADIR_NATIVE}/guile/2.0"
27export GUILE_LOAD_COMPILED_PATH = "${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache"
28
29do_install_append () {
30 create_wrapper ${D}/${bindir}/autogen \
31 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
32 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
33}