blob: 92f4d69d3a0094887de91cfba048c838d2411ba6 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Set of i2c tools for linux"
2SECTION = "base"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5
6SRC_URI = "http://dl.lm-sensors.org/i2c-tools/releases/${BP}.tar.bz2 \
7 file://Module.mk \
8"
9SRC_URI[md5sum] = "7104a1043d11a5e2c7b131614eb1b962"
10SRC_URI[sha256sum] = "db5e69f2e2a6e3aa2ecdfe6a5f490b149c504468770f58921c8c5b8a7860a441"
11
12inherit autotools-brokensep
13
14do_compile_prepend() {
15 cp ${WORKDIR}/Module.mk ${S}/eepromer/
16 sed -i 's#/usr/local#/usr#' ${S}/Makefile
17 echo "include eepromer/Module.mk" >> ${S}/Makefile
18}
19
20do_install_append() {
21 install -d ${D}${includedir}/linux
22 install -m 0644 include/linux/i2c-dev.h ${D}${includedir}/linux/i2c-dev-user.h
23 rm -f ${D}${includedir}/linux/i2c-dev.h
24}
25
26PACKAGES =+ "${PN}-misc"
27FILES_${PN}-misc = "${sbindir}/i2c-stub-from-dump \
28 ${bindir}/ddcmon \
29 ${bindir}/decode-edid \
30 ${bindir}/decode-dimms \
31 ${bindir}/decode-vaio \
32 "
33RDEPENDS_${PN} += "${PN}-misc"
34RDEPENDS_${PN}-misc += "perl"