blob: 497b282074498dd02fa70e28aab587e7ff591ab6 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Note, we can probably remove the lzma option as it has be replaced with xz,
2# and I don't think the kernel supports it any more.
3SUMMARY = "Tools for manipulating SquashFS filesystems"
4SECTION = "base"
5LICENSE = "GPL-2 & PD"
6LIC_FILES_CHKSUM = "file://../COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://../../7zC.txt;beginline=12;endline=16;md5=2056cd6d919ebc3807602143c7449a7c \
8"
9DEPENDS = "attr zlib xz lzo lz4"
10
11PV = "4.3+gitr${SRCPV}"
12SRCREV = "9c1db6d13a51a2e009f0027ef336ce03624eac0d"
13SRC_URI = "git://github.com/plougher/squashfs-tools.git;protocol=https \
14 http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2;name=lzma \
15"
16SRC_URI[lzma.md5sum] = "29d5ffd03a5a3e51aef6a74e9eafb759"
17SRC_URI[lzma.sha256sum] = "c935fd04dd8e0e8c688a3078f3675d699679a90be81c12686837e0880aa0fa1e"
18
19S = "${WORKDIR}/git/squashfs-tools"
20
21# EXTRA_OEMAKE is typically: -e MAKEFLAGS=
22# the -e causes problems as CFLAGS is modified in the Makefile, so
23# we redefine EXTRA_OEMAKE here
24EXTRA_OEMAKE = "MAKEFLAGS= LZMA_SUPPORT=1 LZMA_DIR=../.. XZ_SUPPORT=1 LZO_SUPPORT=1 LZ4_SUPPORT=1"
25
26do_compile() {
27 oe_runmake mksquashfs unsquashfs
28}
29do_install () {
30 install -d ${D}${sbindir}
31 install -m 0755 mksquashfs ${D}${sbindir}/
32 install -m 0755 unsquashfs ${D}${sbindir}/
33}
34
35ARM_INSTRUCTION_SET = "arm"
36
37BBCLASSEXTEND = "native nativesdk"