blob: f8fd39042dac7431beeaf4f43144cb76058a1352 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Target Communication Framework for the Eclipse IDE"
2HOMEPAGE = "http://wiki.eclipse.org/TCF"
3BUGTRACKER = "https://bugs.eclipse.org/bugs/"
4
5LICENSE = "EPL-1.0 | EDL-1.0"
6LIC_FILES_CHKSUM = "file://edl-v10.html;md5=522a390a83dc186513f0500543ad3679"
7
8SRCREV = "b9a735e9c7cf82f80d412b7ab15d08b89d5a4ccc"
9PV = "1.3.0+git${SRCPV}"
10
11SRC_URI = "git://git.eclipse.org/gitroot/tcf/org.eclipse.tcf.agent.git;branch=1.3_mars_bugfix \
12 file://fix_ranlib.patch \
13 file://tcf-agent.init \
14 file://tcf-agent.service \
15 "
16
17DEPENDS = "util-linux openssl"
18RDEPENDS_${PN} = "bash"
19
20S = "${WORKDIR}/git/agent"
21
22inherit update-rc.d systemd
23
24SYSTEMD_SERVICE_${PN} = "tcf-agent.service"
25
26INITSCRIPT_NAME = "tcf-agent"
27INITSCRIPT_PARAMS = "start 99 3 5 . stop 20 0 1 2 6 ."
28
29# mangling needed for make
30MAKE_ARCH = "`echo ${TARGET_ARCH} | sed s,i.86,i686,`"
31MAKE_OS = "`echo ${TARGET_OS} | sed s,^linux.*,GNU/Linux,`"
32
33EXTRA_OEMAKE = "MACHINE=${MAKE_ARCH} OPSYS=${MAKE_OS} 'CC=${CC}' 'AR=${AR}'"
34
35# They don't build on ARM and we don't need them actually.
36CFLAGS += "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \
37 -DSERVICE_Memory=0 -DSERVICE_Registers=0 -DSERVICE_MemoryMap=0 \
38 -DSERVICE_StackTrace=0 -DSERVICE_Symbols=0 -DSERVICE_LineNumbers=0 \
39 -DSERVICE_Expressions=0"
40
41do_install() {
42 oe_runmake install INSTALLROOT=${D}
43 install -d ${D}${sysconfdir}/init.d/
44 install -m 0755 ${WORKDIR}/tcf-agent.init ${D}${sysconfdir}/init.d/tcf-agent
45 install -d ${D}${systemd_unitdir}/system
46 install -m 0644 ${WORKDIR}/tcf-agent.service ${D}${systemd_unitdir}/system
47 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/tcf-agent.service
48}
49