blob: 233fe4c33b1843495cd15994b29f2e4b734fb907 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Very high-quality data compression program"
2DESCRIPTION = "bzip2 compresses files using the Burrows-Wheeler block-sorting text compression algorithm, and \
3Huffman coding. Compression is generally considerably better than that achieved by more conventional \
4LZ77/LZ78-based compressors, and approaches the performance of the PPM family of statistical compressors."
5HOMEPAGE = "http://www.bzip.org/"
6SECTION = "console/utils"
7LICENSE = "bzip2"
8LIC_FILES_CHKSUM = "file://LICENSE;beginline=8;endline=37;md5=40d9d1eb05736d1bfc86cfdd9106e6b2"
9PR = "r5"
10
11SRC_URI = "http://www.bzip.org/${PV}/${BP}.tar.gz \
12 file://configure.ac;subdir=${BP} \
13 file://Makefile.am;subdir=${BP} \
14 file://run-ptest"
15
16SRC_URI[md5sum] = "00b516f4704d4a7cb50a1d97e6e8e15b"
17SRC_URI[sha256sum] = "a2848f34fcd5d6cf47def00461fcb528a0484d8edef8208d6d2e2909dc61d9cd"
18
19PACKAGES =+ "libbz2"
20
21CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
22
23inherit autotools update-alternatives ptest
24
25ALTERNATIVE_PRIORITY = "100"
26ALTERNATIVE_${PN} = "bunzip2 bzcat"
27
28#install binaries to bzip2-native under sysroot for replacement-native
29EXTRA_OECONF_append_class-native = " --bindir=${STAGING_BINDIR_NATIVE}/${PN}"
30
31do_install_ptest () {
32 cp -f ${B}/Makefile ${D}${PTEST_PATH}/Makefile
33 sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile
34}
35
36FILES_libbz2 = "${libdir}/lib*${SOLIBS}"
37
38PROVIDES_append_class-native = " bzip2-replacement-native"
39BBCLASSEXTEND = "native nativesdk"
40