blob: 7fd34aa05f71e53b05e4b87fe1456f2568294a42 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001require recipes-extended/chkconfig/chkconfig_1.3.58.bb
2
3SUMMARY = "${SUMMARY_chkconfig-alternatives}"
4DESCRIPTION = "${DESCRIPTION_chkconfig-alternatives}"
5DEPENDS = ""
6PROVIDES += "virtual/update-alternatives-native"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
9# The sysroot branch is 1.3.59 + some git commits from master + --sysroot
10# support for alternatives.
11SRC_URI = "git://github.com/kergoth/chkconfig;branch=sysroot"
12S = "${WORKDIR}/git"
13
14SRCREV = "cd437ecbd8986c894442f8fce1e0061e20f04dee"
15PV = "1.3.59+${SRCPV}"
16
17inherit native
18
19# We want our native recipes to build using the target paths rather than paths
20# into the sysroot, as we may use them to construct the rootfs. As such, we
21# only adjust the paths to match the metadata for the target, not native.
22obey_variables () {
23 sed -i 's,ALTERNATIVES_ROOT,OPKG_OFFLINE_ROOT,' alternatives.c
24}
25
26do_compile () {
27 oe_runmake alternatives
28}
29
30do_install () {
31 install -d ${D}${sysconfdir}/alternatives \
32 ${D}${localstatedir}/lib/alternatives
33
34 install -D -m 0755 alternatives ${D}${bindir}/alternatives
35 install -D -m 0644 alternatives.8 ${D}${mandir}/man8/alternatives.8
36
37 ln -s alternatives ${D}${bindir}/update-alternatives
38 ln -s alternatives.8 ${D}${mandir}/man8/update-alternatives.8
39}
40
41do_install_append_linuxstdbase() {
42 rm -rf ${D}${libdir}/lsb
43}