blob: 67b6e3749bcfac58714524721ca5a655557e6470 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Lightweight high-performance web server"
2HOMEPAGE = "http://www.lighttpd.net/"
3BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues"
4
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
7
8SECTION = "net"
9DEPENDS = "zlib libpcre"
10RDEPENDS_${PN} += " \
11 lighttpd-module-access \
12 lighttpd-module-accesslog \
13 lighttpd-module-indexfile \
14 lighttpd-module-dirlisting \
15 lighttpd-module-staticfile \
16"
17
18SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.xz \
19 file://index.html.lighttpd \
20 file://lighttpd.conf \
21 file://lighttpd \
22 file://lighttpd.service \
23 file://pkgconfig.patch \
24 file://0001-mod_cgi-buffers-data-without-bound.patch \
25 "
26
27SRC_URI[md5sum] = "1843daffcb018aa528f6d15d43544654"
28SRC_URI[sha256sum] = "897ab6b1cc7bd51671f8af759e7846245fbbca0685c30017e93a5882a9ac1a53"
29
30PACKAGECONFIG ??= "openssl"
31PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl, openssl"
32
33EXTRA_OECONF = " \
34 --without-bzip2 \
35 --without-ldap \
36 --without-lua \
37 --without-memcache \
38 --with-pcre \
39 --without-webdav-props \
40 --without-webdav-locks \
41 --disable-static \
42"
43
44inherit autotools pkgconfig update-rc.d gettext systemd
45
46INITSCRIPT_NAME = "lighttpd"
47INITSCRIPT_PARAMS = "defaults 70"
48
49SYSTEMD_SERVICE_${PN} = "lighttpd.service"
50
51do_install_append() {
52 install -d ${D}${sysconfdir}/init.d ${D}${sysconfdir}/lighttpd.d ${D}/www/pages/dav
53 install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
54 install -m 0644 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
55 install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html
56
57 install -d ${D}${systemd_unitdir}/system
58 install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system
59 sed -i -e 's,@SBINDIR@,${sbindir},g' \
60 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
61 -e 's,@BASE_BINDIR@,${base_bindir},g' \
62 ${D}${systemd_unitdir}/system/lighttpd.service
63 #For FHS compliance, create symbolic links to /var/log and /var/tmp for logs and temporary data
64 ln -sf ${localstatedir}/log ${D}/www/logs
65 ln -sf ${localstatedir}/tmp ${D}/www/var
66}
67
68FILES_${PN} += "${sysconfdir} /www"
69
70CONFFILES_${PN} = "${sysconfdir}/lighttpd.conf"
71
72PACKAGES_DYNAMIC += "^lighttpd-module-.*"
73
74python populate_packages_prepend () {
75 lighttpd_libdir = d.expand('${libdir}')
76 do_split_packages(d, lighttpd_libdir, '^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='')
77}