blob: ce823858ce355694b06557f8e4be46f2e7a709a5 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# Copyright (C) 2010 Intel Corporation
3#
4
5SUMMARY = "Linux Standard Base (LSB)"
6DESCRIPTION = "Packages required to satisfy the Linux Standard Base (LSB) specification"
7PR = "r10"
8LICENSE = "MIT"
9
10inherit packagegroup distro_features_check
11
12# The libxt, libxtst and others require x11 in DISTRO_FEATURES
13REQUIRED_DISTRO_FEATURES = "x11"
14
15#
16# We will skip parsing this packagegeoup for non-glibc systems
17#
18python __anonymous () {
19 if d.getVar('TCLIBC', True) != "glibc":
20 raise bb.parse.SkipPackage("incompatible with %s C library" %
21 d.getVar('TCLIBC', True))
22}
23
24PACKAGES = "\
25 packagegroup-core-lsb \
26 packagegroup-core-sys-extended \
27 packagegroup-core-db \
28 packagegroup-core-perl \
29 packagegroup-core-python \
30 packagegroup-core-tcl \
31 packagegroup-core-lsb-misc \
32 packagegroup-core-lsb-core \
33 packagegroup-core-lsb-perl \
34 packagegroup-core-lsb-python \
35 packagegroup-core-lsb-desktop \
36 packagegroup-core-lsb-runtime-add \
37 "
38
39
40RDEPENDS_packagegroup-core-lsb = "\
41 packagegroup-core-sys-extended \
42 packagegroup-core-db \
43 packagegroup-core-perl \
44 packagegroup-core-python \
45 packagegroup-core-tcl \
46 packagegroup-core-lsb-misc \
47 packagegroup-core-lsb-core \
48 packagegroup-core-lsb-perl \
49 packagegroup-core-lsb-python \
50 packagegroup-core-lsb-desktop \
51 packagegroup-core-lsb-runtime-add \
52 "
53
54
55RDEPENDS_packagegroup-core-sys-extended = "\
56 curl \
57 dhcp-client \
58 hdparm \
59 lighttpd \
60 libaio \
61 lrzsz \
62 lzo \
63 mc \
64 mc-fish \
65 mc-helpers \
66 mc-helpers-perl \
67 mc-helpers-python \
68 mdadm \
69 minicom \
70 neon \
71 parted \
72 ${PTH} \
73 quota \
74 screen \
75 setserial \
76 sysstat \
77 udev-extraconf \
78 unzip \
79 watchdog \
80 wget \
81 which \
82 xinetd \
83 zip \
84 "
85
86RDEPENDS_packagegroup-core-db = "\
87 db \
88 sqlite3 \
89 "
90
91RDEPENDS_packagegroup-core-perl = "\
92 gdbm \
93 perl \
94 zlib \
95 "
96
97
98RDEPENDS_packagegroup-core-python = "\
99 expat \
100 gdbm \
101 gmp \
102 ncurses \
103 openssl \
104 python \
105 readline \
106 zip \
107 "
108
109RDEPENDS_packagegroup-core-tcl = "\
110 tcl \
111 "
112
113# Miscellaneous packages required by LSB (or LSB tests)
114RDEPENDS_packagegroup-core-lsb-misc = "\
115 chkconfig \
116 gettext \
117 gettext-runtime \
118 groff \
119 lsbinitscripts \
120 lsbtest \
121 lsof \
122 strace \
123 libusb1 \
124 usbutils \
125 rpm \
126 "
127
128SUMMARY_packagegroup-core-lsb-core = "LSB Core"
129DESCRIPTION_packagegroup-core-lsb-core = "Packages required to support commands/libraries \
130 specified in the LSB Core specification"
131RDEPENDS_packagegroup-core-lsb-core = "\
132 at \
133 bash \
134 bc \
135 binutils \
136 binutils-symlinks \
137 coreutils \
138 cpio \
139 cronie \
140 cups \
141 diffutils \
142 ed \
143 glibc-utils \
144 elfutils \
145 file \
146 findutils \
147 fontconfig-utils \
148 foomatic-filters \
149 gawk \
150 ghostscript \
151 grep \
152 gzip \
153 localedef \
154 lsb \
155 m4 \
156 mailx \
157 make \
158 man \
159 man-pages \
160 mktemp \
161 msmtp \
162 patch \
163 pax \
164 procps \
165 psmisc \
166 sed \
167 shadow \
168 tar \
169 time \
170 util-linux \
171 xdg-utils \
172 \
173 glibc \
174 libgcc \
175 libpam \
176 libxml2 \
177 ncurses \
178 zlib \
179 nspr \
180 libpng12 \
181 nss \
182"
183
184SUMMARY_packagegroup-core-lsb-perl = "LSB Runtime Languages (Perl)"
185DESCRIPTION_packagegroup-core-lsb-perl = "Packages required to support libraries \
186 specified in the LSB Runtime languages specification (Perl parts)"
187RDEPENDS_packagegroup-core-lsb-perl = "\
188 perl \
189 perl-modules \
190 perl-misc \
191 perl-pod \
192 perl-dev \
193 perl-doc \
194"
195
196SUMMARY_packagegroup-core-lsb-python = "LSB Runtime Languages (Python)"
197DESCRIPTION_packagegroup-core-lsb-python = "Packages required to support libraries \
198 specified in the LSB Runtime languages specification (Python parts)"
199RDEPENDS_packagegroup-core-lsb-python = "\
200 python \
201 python-modules \
202 python-misc \
203"
204
205def get_libqt3(d):
206 if 'linuxstdbase' in d.getVar('DISTROOVERRIDES', False) or "":
207 if 'qt3' in d.getVar('BBFILE_COLLECTIONS', False) or "":
208 return 'libqt-mt3'
209
210 bb.warn('The meta-qt3 layer should be added, this layer provides Qt 3.x' \
211 'libraries. Its intended use is for passing LSB tests as Qt3 is' \
212 'a requirement for LSB.')
213 return ''
214
215QT4PKGS = " \
216 libqtcore4 \
217 libqtgui4 \
218 libqtsql4 \
219 libqtsvg4 \
220 libqtxml4 \
221 libqtnetwork4 \
222 qt4-plugin-sqldriver-sqlite \
223 ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "libqtopengl4", "", d)} \
224 "
225QT4PKGS_mips64 = ""
226QT4PKGS_mips64n32 = ""
227
228SUMMARY_packagegroup-core-lsb-desktop = "LSB Desktop"
229DESCRIPTION_packagegroup-core-lsb-desktop = "Packages required to support libraries \
230 specified in the LSB Desktop specification"
231RDEPENDS_packagegroup-core-lsb-desktop = "\
232 libxt \
233 libxxf86vm \
234 libdrm \
235 libglu \
236 libxi \
237 libxtst \
238 libx11-locale \
239 xorg-minimal-fonts \
240 gdk-pixbuf-loader-ico \
241 gdk-pixbuf-loader-bmp \
242 gdk-pixbuf-loader-ani \
243 gdk-pixbuf-xlib \
244 liberation-fonts \
245 gtk+ \
246 atk \
247 libasound \
248 ${QT4PKGS} \
249 ${@get_libqt3(d)} \
250"
251
252RDEPENDS_packagegroup-core-lsb-runtime-add = "\
253 ldd \
254 pam-plugin-wheel \
255 e2fsprogs-mke2fs \
256 mkfontdir \
257 liburi-perl \
258 libxml-parser-perl \
259 libxml-perl \
260 libxml-sax-perl \
261 glibc-localedatas \
262 glibc-gconvs \
263 glibc-charmaps \
264 glibc-binaries \
265 glibc-localedata-posix \
266 glibc-extra-nss \
267 glibc-pcprofile \
268 libclass-isa-perl \
269 libenv-perl \
270 libdumpvalue-perl \
271 libfile-checktree-perl \
272 libi18n-collate-perl \
273 libpod-plainer-perl \
274"
275
276PTH = "pth"
277PTH_libc-uclibc = ""
278