blob: 0330981af3374899ab9bdc809c9d057f946ec6e2 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "PBZIP2 is a parallel implementation of bzip2"
2DESCRIPTION = "PBZIP2 is a parallel implementation of the bzip2 block-sorting \
3file compressor that uses pthreads and achieves near-linear speedup on SMP \
4machines. The output of this version is fully compatible with bzip2 v1.0.2 or \
5newer (ie: anything compressed with pbzip2 can be decompressed with bzip2)."
6HOMEPAGE = "http://compression.ca/pbzip2/"
7SECTION = "console/utils"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;md5=4c4f2edec9679d5abef3514a816b54a4"
10
11DEPENDS = "bzip2"
12DEPENDS_append_class-native = " bzip2-replacement-native"
13
14SRC_URI = "https://launchpad.net/${BPN}/1.1/${PV}/+download/${BP}.tar.gz"
15
16SRC_URI[md5sum] = "91a4911b13305850423840eb0fa6f4f9"
17SRC_URI[sha256sum] = "573bb358a5a7d3bf5f42f881af324cedf960c786e8d66dd03d448ddd8a0166ee"
18
19do_configure[noexec] = "1"
20
21EXTRA_OEMAKE = "CXX='${CXX} ${CXXFLAGS}' LDFLAGS='${LDFLAGS}'"
22
23do_install() {
24 install -d ${D}${bindir}
25 install -m 0755 pbzip2 ${D}${bindir}/
26}
27
28BBCLASSEXTEND = "native"