blob: 8fb715a11e2cc231c84032b4c1ef4ce93f88ab5f [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Documentation system for on-line information and printed output"
2DESCRIPTION = "Texinfo is a documentation system that can produce both \
3online information and printed output from a single source file. The \
4GNU Project uses the Texinfo file format for most of its documentation."
5HOMEPAGE = "http://www.gnu.org/software/texinfo/"
6SECTION = "console/utils"
7LICENSE = "GPLv3+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9
10PROVIDES_append_class-native = " texinfo-replacement-native"
11
12def compress_pkg(d):
13 if "compress_doc" in (d.getVar("INHERIT", True) or "").split():
14 compress = d.getVar("DOC_COMPRESS", True)
15 if compress == "gz":
16 return "gzip"
17 elif compress == "bz2":
18 return "bzip2"
19 elif compress == "xz":
20 return "xz"
21 return ""
22
23RDEPENDS_info += "${@compress_pkg(d)}"
24
25DEPENDS = "zlib ncurses texinfo-replacement-native"
26DEPENDS_class-native = "zlib-native ncurses-native"
27
28TARGET_PATCH = "file://use_host_makedoc.patch"
29TARGET_PATCH_class-native = ""
30
31SRC_URI = "${GNU_MIRROR}/texinfo/${BP}.tar.gz \
32 file://texinfo-4.12-zlib.patch \
33 file://disable-native-tools.patch \
34 file://link-zip.patch \
35 file://dont-depend-on-help2man.patch \
36 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
37 ${TARGET_PATCH} \
38 "
39
40SRC_URI[md5sum] = "e1a2ef5dce5018b53f0f6eed45b247a7"
41SRC_URI[sha256sum] = "83d3183290f34e7f958d209d0b20022c6fe9e921eb6fe94c27d988827d4878d2"
42
43tex_texinfo = "texmf/tex/texinfo"
44
45inherit gettext autotools
46
47do_configure_prepend () {
48 # autotools_do_configure updates po/Makefile.in.in, we also need
49 # update po_document.
50 cp -f ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po_document/
51}
52
53do_compile_prepend() {
54 if [ -d tools ];then
55 oe_runmake -C tools/gnulib/lib
56 fi
57}
58
59do_install_append() {
60 mkdir -p ${D}${datadir}/${tex_texinfo}
61 install -p -m644 ${S}/doc/texinfo.tex ${S}/doc/txi-??.tex ${D}${datadir}/${tex_texinfo}
62 sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/texi2any ${D}${bindir}/pod2texi
63}
64
65do_install_append_class-native() {
66 install -m 755 info/makedoc ${D}${bindir}
67}
68
69PACKAGES += "info info-doc"
70
71FILES_info = "${bindir}/info ${bindir}/infokey ${bindir}/install-info"
72FILES_info-doc = "${infodir}/info.info* ${infodir}/dir ${infodir}/info-*.info* \
73 ${mandir}/man1/info.1* ${mandir}/man5/info.5* \
74 ${mandir}/man1/infokey.1* ${mandir}/man1/install-info.1*"
75
76FILES_${PN} = "${bindir}/makeinfo ${bindir}/texi* ${bindir}/pdftexi2dvi ${bindir}/pod2texi ${datadir}/texinfo"
77RDEPENDS_${PN} = "perl"
78FILES_${PN}-doc = "${infodir}/texinfo* \
79 ${datadir}/${tex_texinfo} \
80 ${mandir}/man1 ${mandir}/man5"
81
82BBCLASSEXTEND = "native"