blob: 46f1e3c6e39fafbff28da82f2086023b18a28c1f [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Basic desktop integration functions"
2
3DESCRIPTION = "The xdg-utils package is a set of simple scripts that provide basic \
4desktop integration functions for any Free Desktop, such as Linux. \
5They are intended to provide a set of defacto standards. \
6The following scripts are provided at this time: \
7xdg-desktop-icon \
8xdg-desktop-menu \
9xdg-email \
10xdg-icon-resource \
11xdg-mime \
12xdg-open \
13xdg-screensaver \
14xdg-terminal \
15"
16
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://LICENSE;md5=a5367a90934098d6b05af3b746405014"
19
20SRC_URI = "http://portland.freedesktop.org/download/${BPN}-${PV}.tar.gz \
21 file://0001-Reinstate-xdg-terminal.patch \
22 "
23
24SRC_URI[md5sum] = "fadf5e7a08e0526fc60dbe3e5b7ef8d6"
25SRC_URI[sha256sum] = "7b05558ae4bb8ede356863cae8c42e3e012aa421bf9d45130a570fd209d79102"
26
27inherit autotools-brokensep distro_features_check
28
29# The xprop requires x11 in DISTRO_FEATURES
30REQUIRED_DISTRO_FEATURES = "x11"
31
32RDEPENDS_${PN} += "xprop"